"No transaction is active" error in SQL Server Trigger for data insertion into Linked Server's table

I am created a trigger on SQL Server’s table for inserting data into a table on Linked Server and getting following error:

7391,“42000”,[Microsoft][ODBC SQL Server Driver][SQL Server]The operation could not be performed because OLE DB provider “SQLNCLI10” for linked server “ServerName” was unable to begin a distributed transaction.
7412,“01000”,[Microsoft][ODBC SQL Server Driver][SQL Server]OLE DB provider “SQLNCLI10” for linked server “ServerName” returned message “No transaction is active.”.
The issue is happening in Trigger only, whereas using a query I am able to write/fetch data to/from that particular table in Linked Server.

What I have already tried: On some of the blogs, it was mentioned that one should
Stop MSDTC Service
Un-install MSDTC Service
Install MSDTC Service
and restart both the servers. This I have already tried.

Can someone please suggest the possible solution for this issue. Thanks in advance.