No Server in Development Environment


I have a fresh install of Dynamics Nav 2013 : sql & Nav Server on a dedicated server.

On another server I installed RTC & Development Environment

RTC works fine.

When I go in the Development Environment, File / Database / Open there is no Server name available.

I saw some posts where you have put in the server instance in Tools / Options.

This is what I tried :


But this did not change anything :frowning:

Would be nice to have some help to find a way to find the server !

You can add the server name while opening the database.

once you enter server name manually then you can select the databases available in that server by lookup.

Here you have to select the database server (i.e. SQL Server), not the application server (i.e. service tier)

In SQL server management studio I can see the instance - its kind of nameofwindowsserver\instancename

I tried to enter :

nameofwindowsserver\instancename : I get error “The … server cannot be found.”

instancename : I get error “The … server cannot be found.”

When I’m on the Nav Server, I can open the base in Development Environment without any problem - Ok there I can select it but the text there is nameofwindowsserver\instancename.

I do not understand why this does not work on the other server.

If you are connecting from a different machine you should verify that the firewall is not blocking the communication with the SQL Server. The SQL Server ports are not open by default.

OK as by default its not open I did nothing to open it, it seems to be normal that I can’t reach the SQL database.

I’m on Windows Server 2012 and SQL Server 2012.

I had a look in the SQL Server Configuration Manager at the TCPIP protocole of my database instance :

There are different entries (IP1, IP2, …) but no TCP port, execpt the last one IPAII, who has a dynamic TCP port.

I’m not sure how toi proceed so could you give me some hints to find out waht are the rule(s) I have to add to the firewall ?

The standard port is 1433. You can also try <ip_address>\Instance. I have seen cases where the browser service being off contributed to connection via the machine name (DNS).

Thanks - I added a rule authorizing port 1433 but same result

I also Tried with IP adress - no difference :frowning:

On both computers?

If ICMP/Ping is open can you ping the machine?

On the SQL Server machine open a command prompt and click netstat -an then search that for port 1433

netstat : no port 1433

ping : no response

netstat : no port 1433

ping : no response