Need to add a field inside mapping on Table in D365

In D365, i created a Table Extension and added a new field in PurchParmTable

EX field is : Test

now i need to add this Test field inside mapping>>VendDocumentTableMap

but i can’t create the Test field

how to add a field inside mapping, is there any other way to achieve this???


It is possible only when you create new mapping in Extension table for specific map because restoring or refreshing the table is not available in D365.

thanks bro

If it answered your question, please verify it to make clear that the problem has been resolved.

In extension table i create a new mapping, because in extension i can’t edit existing mapping

if i created new mapping in extension with table name it shows error

Severity Code Description Project File Line Suppression State

Error Path: [AxTableExtension/PurchTable.Extension]:The mapping ‘CurrencyCodeMap’ on the extension ‘PurchTable.Extension’ already exists. This extension cannot be applied to the base element. LocationField(PO) (VAR) [AAA] C:\AOSService\PackagesLocalDirectory\ApplicationSuite\AAA\AxTableExtension\PurchTable.Extension.xml 0

For that i did in customization table, just choose the exist map and change its map name to some other mapping value and choose the correct map now my new field came in mapping

for example:

In properties

Map: VendDocumentTableMap (choose another map name like CurrencyCodeMap after that choosed VendDocumentTableMap then only my newly added field will came inside map, and need to select mapping fields for every field, existing mapping will gone)

If there is any solution, kindly share…


Can you please tell me where the new field is added Whether in Extension or Standard Object?

new field is added in the PurchParmTable.Extension

In Extension Only

Actually Extension fields doesn’t display on Standard objects due to Model References or Model InCompatibility.Is the new field added in Extension is displayed in Standard object?

Sorry bro i added field in customization then only i got it, little confusion bro…
initially tried with extension but its not worked

That’s ok.