need help - Faulting application ax32.exe

i try to run axapta 3.0 sp3 using AOS, but always fail, axapta shutdown immediatelly and AOS suddenly stopped.I check the event viewer and get this message. “Faulting application ax32.exe, version 3.0.1951.3730, stamp 40589f7c, faulting module ax32.exe, version 3.0.1951.3730, stamp 40589f7c, debug? 0, fault address 0x0023a831.” Can anybody help me? I really appreciate it…thanks…

I think you need to consider if the AOS is running the correct .exe file. You will need to provide the correct path from Startup button in Axapta Server Manager utility. This way you ensure that it is running the correct version for AOS server (the same SP as the client), because in environments where there are multiple Service Packs running simultaneously there can be conflicts in this area.

thanks for ur reply ciprian,i tried ur suggestion and now the message turn to “Concurrent number of AOS’ for this application exceeds the licensed number.” i tried to search the web for the solution,i found 2 solution. 1.Try to edit a regedit entry( enableoplocks or oplocksdisabled), but i cannot i find both of the regedit entry in my regedit tree, i am using windows xp SP2. 2.Try to get kernel update for axapta, but this option seems impossible coz it resides in microsoft partnersource download. My question is installing SP4/SP5 will resolve this problem? or do you have any suggestion about this issue? Thanks

No. The reason for the new error is you don’t have enough license rights to run multiple AOS’s. You are already running one AOS and the second is not allowed for the same Application. You can check this in Main menu\Administration\Setup\System\License information\ Axapta Object Servers. It is probably limited to 1.

On the AOS you need to add a key:


Name: EnableOplocks
Value: 0

That should do the trick