Navision tries to reinstall when selecting F1 (help)


Everytime I run help (press F1) in Navision, it tries to install something. I getthe usually dialog message “please wait while windows configures Microsoft Navision Attain”. If I press cancel about 10 times it eventually stops displaying the install dialog message and then help opens and works fine.

If I complete what it thinks is the installation it will only do it again next time.

I’ve seen this before ages ago but I can’t remember the fix. Any ideas?

We are running the 3.60 version of the SQl client on Windows 2000 Terminal., BTW.

Many Thanks.

It’s being doing this since my profile was reset to fix my email… but it is a real pain.

Read this topic

Hi, Thanks for that. I suppose we could try to reinstall via that method. However, it’s strange that the problem is not apparent to all users. Some users hit the F1 key and load up HELP without any problems


Hi Tim,

that other post only covers a small part of the issue.

basically this is a known bug in 3.60. And in two service pack releases, it never really got fixed. Yes there are work arounds but they are not ideal.

My recommendation is to do a technical upgrade to 3.70B which does fix this issue. A technical upgrade only takes a few hours, and you can do it your self.

Note that if you are ona support contract, then a better solution is to use 4.00 SP3.

Even with 3.70b I had the same issue. Has necessary to do some manual operations.

It relates to Security settings for the particular user (Windows security, not Navision). This is due to the way that Navision is trying to access the “Company notes” feature. To confirm that this is the issue, Try turning off company Notes, and see if the problem goes away.

Another thing you can try, is to open the Navision folder, and drag fin.exe onto the desktop and create a short cut. Then see if running from the short cut works.

Hi, Thanks for all replies so far…I missed the follow up replies to this and have been putting up with the problems ever since :slight_smile: I tried to remove the company notes setup… we weren’t using it (no path declared in the setup) but I deleted the record none the less. Still happens I’m afraid. Also the same if I shortcut the finsql.exe. The security side seems possible since it only occurs for me and not all users…but don’t have a clue how to fix it. Upgrade of the client version is probably the option but not sure we want to go this way as of yet. Thanks in advance for any inspired solutions…