NAV 2018 installation: Database already exists

HI All,

Has anyone come across with issue installing NAV 2018 CU5 demo

I keep getting the below error when i installed

A database with name demo database nav 11-0 already exists. delete this database in SQL management studio run setup.exe again and click repair

But there is no demo database exists in SQL



There can only be two situation where you can get this error message

  1. You DO have a demo database installed (in 99,9% of all cases it is the issue) - Be aware of that you might have more than one SQL installed!!!

  2. You did not run the SETUP.EXE as administrator.

If no. 2 does not fix your issue… then there are no question about it… you do have a database installed!

Yes, same has happened to me once or twice. I already had a SQL Server standard installed, but NAV still installed an SQL Server Express instance in a newer version. So check for a different SQL instance. And always “RUN AS ADMINISTRATOR”, whenever you need to install NAV. Even if your account is setup as the administrator, then this is still required for the installation program to gain full access to your computer.

You may also just select to replace existing database when installing. This is one of the custom options you can change, before installing.

And as a separate question. If you need a NAV 2018 demo to “play with”, then why didn’t you use Docker? Personally I have not even installed NAV the last year or so by running SETUP.EXE. For demo, test and development purposes, then I only use Docker containers. And I do install NAV a lot! With Docker, then all you need to install any version of NAV, from NAV 2015 and up till the newest previews, is a single PowerShell command and NavContainerHelpers. Learning to install Docker and use it with NAV takes an hour or three. There are plenty of documentation on how to do it.

I have moved your question from the developer forum, into the technical forum. This is where this question should have been asked.

HI Palle,

I have 2017 Demo Database installed previously, I have deleted the existing database and restarted the service and it worked

Thank you so much for giving me suggestions


Thank you Erik,I have followed all your instructions and it worked finally

Thanks EriK , I Will definitely try to use Docker containers

can you please share the link for the documentation