NAV 2016/2017 Development Environment

Hi Forums Team members,

We have a situation, where we are trying to use Azure VM as our NAV Server and SQL Database Server and when we trying to save changes in the Table. We get the following error.

NAV Compile ISSUE.png

Please find below further more environment details for your information.

  1. NAV Server and SQL Server is hosted on AZURE VM
  2. NAV Development Environment and client works fine, when connect Azure VM through RDC.
  3. NAV Client can be connected to NAV Service from outside Azure VM with NAVUserPassword credential type
  4. NAV environment is having single database multiple companies in is having single Tenant.
  5. When the Development Environment of NAV 2016 cumulative update 9 or NAV 2017 Cumulative update 1 is opened in Azure VM, we can compile and save tables.
  6. But when we open Development Environment of NAV 2016 cumulative update 9 or NAV 2017 cumulative update 1 in developer Laptop, and try to make changes or add new fields in the tables we get above error.

We have already tried following things to resolve the above issue, but the issue is not resolved.

  1. Turned off Windows Firewall on both Azure VM and developer laptop (Windows 10 Enterprise Edition)
  2. Management service is also configured in NAV service and endpoint is also configured on Azure cloud
  3. Configured in development environment in Tools → Options, entered server port, service name and management port.

But still not outcome.

Do any one have configured similar type of environment and it is working fine.

Whats logged in the Event Viewer??

Hello RockwithNav,

No event is registered in Event viewer, at both the END (Azure VM, where NAV Server is installed and the Client from where Development Environment is running)

Hi Ma,
And I assume that you’ve tried running the DE directly on the VM? You’re sure its not a permission issue? The user is a DBO?

When I faced this problem, running the developer environment as an administrator, and selecting the correct nav service when compiling helped. If you select wrong nav service, then you will not be able to compile, you have to close the client and log back in.

If you are using Development environment with SQL logins and with NavUserPassword authentication , you have to have same username and password in SQL and in NAV in order to make it work. - I will blog one day about this, it is worth a longer post.

Development client and NAV service both have to have same authentication method. You cannot have Windows login in Development environment and NAVUserPassword in RTC at the same time.

If you are using externally only NavUserPassword authentication, on developer’s laptop, check file:
C:\ProgramData\Microsoft\Microsoft Dynamics NAV\90\ClientUserSettings.config
It has to have entries that reflect the NAV service in the Azure server in following elements: Server, ClientServicesPort, ServerInstance and ClientServicesCredentialType

br, urpo