NAV 2009 RTC RDLC reporting

I have a report which shows the date in the correct format DD/MM/YY in classic view, however when the report is run in RTC mode the date appears DD/MM/YYYY… how can I format the fields so they appear as DD/MM/YY?

Did you try by simply adding d in formatexpression property of date text box in rtc?

Open rtc report(rdlc in visual studio)

select date field

selct formatexpression

enter d


Its currently set to ‘d’ at the moment and the date appears in the format dd/mm/yyyy. I think I need a new format expression so that it displays the date format dd/mm/yy.

Did you try with Format function?

I know that his may be little hard coded… but i u are desparate u can use below syntax… in the


Mohana, I think what you are suggesting was already in the RDL layout anyway, however I have overcome this issue by amending the properties of the field > Format Tab > set the Format code to = 'dd/MM/yy" which looks like a similar suggestion by Anil (Thanks). This solved the issue.

One thing I did try before this was to set my system date properties for short date = dd/MM/yy but nothing happened. Note that the ‘d’ refers to the systems short date, hence I thought maybe if the format was changed at system level it might help. A system reboot may have made it work but setting the format within the report itself was a better option, hence not dependent on the short date format set on individual PC’s.

You are welcome… i am glad that it worked… yes always make report generic for all users rather than setting the pc date format for all machines (it won’t work though)