Module missing from navigation pane options

Hi,

There is an issue, to user when i try to add a module from the navigation options menu, a menu item is missing from the list. Does any body know how can it be fixed?

Thanks,

Does the user has access to the menu item/entry point?

How can check that?

You can check from the roles assigned to that user.

User has role assigned to him… But still he not able add the Menu from the navigation pane list.

So the menu item missing is a part of one of the roles assigned to the user?
Does the other users able to see that menu item?

Also check, that the menu item is not country specific.

So the menu item missing is a part of one of the roles assigned to the user? ANs: Yes
Does the other users able to see that menu item? Ans: If the other user is assigned to same role, he can view the menu item.

Where can i check if the menu is country specific or not? where can i see them

If the menu item has country region codes(property of menu item) on it, then it is country specific.
The country specific part may not be relevant if there are different users in same company with same roles assigned and one of them cannot see one menu item. Is that what happening your case? If so have you tried by re-assigning the roles to the user.

What do you mean by “to add a module from the navigation options menu”? Didn’t you create a completely new menu? If so, it won’t be displayed in the main menu unless you explicitly add it there.

Hey Martins

My user is assigned to access a particular module using security. Now when he opens AX , he cannot find the relevant module in the navigation pane. So, he tried to check if the module exist in the navigation pane list, but it doesn’t. to test, i assigned the same role to my user and checked it AX, for me the module is added in the navigation pane and also exist in the navigation pane list. So i am sure what would have caused this in case of this user.

Menu and Menu items are different. Don’t use one in the place of other while explaining.
Please don’t hesitate to provide as much information possible, so that others won’t spend much time in extracting the requirement/issue from you.

Okay. I get that. Sorry for the inconvenience. Do you need more information?

Not sure if your problem is resolved. So if not, please try to perform the tasks listed below.

1st thing, screenshots always help. So if possible, please provide screenshots of how you see the navigation list and how the user sees it.

2nd thing, screenshot of the user rights provided to your user & to the user facing this issue.

This might be a caching issue, if both users have same rights. Have you tried generating CIL, restarting AX services, etc.? Have you tried clearing the ax cache or the user’s usage data, if possible? This helps narrowing down the problem.

Thanks Krupa,

But by clearing the usage data, will the user’s role centre settings get deleted? Can i know that!

Their personalizations in the system will get deleted, for sure. I have faced such issues so many times & clearing the usage data of the user has always helped with this. But there can be multiple reasons for this issue.
You need to ensure that CIL is generated before performing any tasks. Sometimes without that, the new code or changes are not reflected.

I had also asked if you could provide screenshots of what you see from both the user accounts? It will give us a better visual on the problem.

pastedimage1492672578600v1.png pastedimage1492672609064v2.png

so a module AP is missing in the left screen shot. both of has the security role of sys admin and sales manager

It seems that your scroll bar is not on top. Can you see anything above the Accounts Receivable options? Has the user moved the module else where, as the user can change the order. You can also try to use the reset button for the user, because it will bring back the standard order.

Krupa, i had intentionally added that screen shot. Because my user is not providing me with correct screen shot showing the issue. SO based on the issue explanation the user gave me i had given this screen shot. Basically, the user is not able to see the AP in the given list.