Missing Zup file

Hi developers,

working with NAV native db, two (only two) of our users have problems printing invoices… the program displays an error and the printing never start. I’ve read this could be solved deleting the .zup file (don’t know why), but such a surprise when I go to “C:/Documents and Settings/userName/” and no .zup file is located there, more than that, no .zup file is stored on any client, even if they are asked for this file to be replaced when they close session.

Can somebody help me with this, printing or zup, affairs?
Thank :wink:

Hi Galletin,

Have you checked if an alternative location for the zup-file has been put in the properties of the exe-file shortcut?
e.g. ID=\Server\Share<%USER%>.zup (or something like that [:D])

I once had a customer who wanted to use the same zup-file for the user, no matter on wich workstation he/she logged on from.
By putting a parameter like this one, then the zup-file is stored on a network share, and are accessable from every workstation.

Hi Alexander,

no parameter in this way is passed, I just use params for servername,nettype,ntauthentication and Company. I tried searching for *.zup files on the server too and no file was found. How is possible that users are requested to overwrite the zup file but no zup file is located neither on their computers nor on the server?

Thanks anyway

Normally the zup file is stored under the Application Data folder.

C:\Documents and Settings\UserName\Application Data

This is a hidden folder.

Yes munib00 I know, the folder exists and hidden files are showed :frowning:

When workign in Navision, all your settings are saved in a file in the temporary directory. When you close Navision out it trys to save these changes as the ZUP file. If you don’t have permission to that folder where the ZUP file should be then it can’t save it. I suggest that you force the ZUP file to a specific location, then loged is as the user make sure you have permission to that folder.

Hi galletin,

It has happened with me many times … look here are several solutions

1st solution/ Sometimes i can get it from search on windows for fin.zup .

2nd solution/ Be sure tha you are showing hidden files … even i know you apply it … but after applying it go again and check it … it happened with me that once time i 've got virus prevent me from showing hidden file …even i was sure of clicking on Apply button

4th solution … when you went documents and settings / user name … do you have another user name on that computer … if you have another user check the zup file on another user name …be sure also with the network adminstrator that every thing is okay … once time a big conflict was happened between users from network …by renaming users … and i asked from the network administrator to fix it so that after i could see the zup file .

Any way …it must be somewhere…i only post my experience may it will help you .

Thanks for replies, I tried the solutions exposed but, at the begining, everything is ok but the zup files.

I think I’ll try to configure NAV for users to store zup files on the server… the first post talked about it, I read about the existence of “roamming” users but no more info was displayed… can you tell me something about it?


Hi Galletin,


You’ll need to apply this to the shortcut of the exe-file used for opening Navision.

Go to the property-window of the shortcut, and in the “Start in” field apply the startup parameter to the end of the already existing string.
NB! remember to put a space in between.

The parameter should be something like this:
(Remember to give users edit-rights to the share, you could also consider making the share hidden)
This will cause an individual zup-file to be created for each user, at the location defined.

The ID-parameter tells navision to overrule the default path of the zup-file.


Not the “Start in” property, but the “Destination” property.

Perfect Alexander,

I tried with my user and the zup file is succesfully created, I hope to be able to solve the printing problems deleting user’s zup file.

Thanks, thanks and thanks again [:D]