metadata error

Dear All,

i am facing a problem while opening a page. it says the metadata of the table is invalid. see event viewer for more details. when i look into event viewer i saw this mesez ::

Service: MicrosoftDynamicsNavServer
User: W08-DB01\Chandra
Type: System.Xml.XmlException
LineNumber: 43
LinePosition: 182
Message: ‘’, hexadecimal value 0x14, is an invalid character. Line 43, position 182.
at System.Xml.XmlTextReaderImpl.Throw(Exception e)
at System.Xml.XmlTextReaderImpl.Throw(String res, String[] args)
at System.Xml.XmlTextReaderImpl.Throw(Int32 pos, String res, String[] args)
at System.Xml.XmlTextReaderImpl.ThrowInvalidChar(Int32 pos, Char invChar)
at System.Xml.XmlTextReaderImpl.ParseAttributeValueSlow(Int32 curPos, Char quoteChar, NodeData attr)
at System.Xml.XmlTextReaderImpl.ParseAttributes()
at System.Xml.XmlTextReaderImpl.ParseElement()
at System.Xml.XmlTextReaderImpl.ParseElementContent()
at System.Xml.XmlTextReaderImpl.Read()
at System.Xml.XmlLoader.LoadNode(Boolean skipOverWhitespace)
at System.Xml.XmlLoader.LoadDocSequence(XmlDocument parentDoc)
at System.Xml.XmlLoader.Load(XmlDocument doc, XmlReader reader, Boolean preserveWhitespace)
at System.Xml.XmlDocument.Load(XmlReader reader)
at System.Xml.XmlDocument.LoadXml(String xml)
at Microsoft.Dynamics.Nav.Service.Metadata.MetadataProvider.GetNavObjectAsXMLDocument(Int32 id, ObjectType navObjectType)
at Microsoft.Dynamics.Nav.Service.Metadata.MetadataProvider.<>c__DisplayClass1.b__0()
Source: System.Xml

what may be the problem ?? i couldnt identify the problem…

Did you try by compiling the table and page?

if not, compile all objects

Dear Mohana,

yes i have already compiled all the objects but still the error occurs. any other idea ? i have also started the service and tried to open the page but didn’t work…



I would suggest that firstly remove the entry for that specific table from Object Metadata table and then compile the object and check

Dear All,

Thank you for all your valuable replies… I have solved the problem…



How did you solve the problem?

It can help others in future.

this error was caused due to some caption mismatch and compilation did the magic…!!!