Main Menu not appearing

I have a strange problem. When I log on to Axapta (2-Tier mode) as Admin, the main menu does not appear. I don’t have access to the AOT either. How can I fix this problem? My bin and system directory in the configuration are correct.

Hi, Have you tried with “File\Open\Main Menu”? Ciprian

Usually you don’t get acces to AOT when you are running in Demo mode (meaning that the license codes are not correct). However, you should have acces to Main menu anyway.

My license codes are correct and File\Open\Main Menu does not work.

Hi Cachelle, It is kind of bizarre! Please let us know the following - - what happens when you log in 3-tier ? - what happens when you log in 2-tier with a different user ID? - what is the version of Axapta client and application? - last but not least, is this a new system? Kind regards, Harish Mohanbabu

  • Not using 3-tier - Same thing happens when logging on with a different Id - Axapta 3.0 Sp3 - IBM T40

Hi, Apologies for not being clear. By new system, what I meant was whether is this a new or old Axapta installation. If it is a new installation, can you let us know the order in which you installed Axapta please. Also do you get any error messages? Are there any entries in the Event viewer at all? Regards, Harish Mohanbabu

Hi Harrish, I have totally the same problem today. - 2-tier instalation (no 3-tier config). - license is ok. - new instalation on my computer. *** No spaecial Error message during the instalation and compilation from the check list steps, except sometimes is complains that : Can not create User Admin, the record is already exists!!! Hope this can give you more information.

Hi, I would start checking in this order - - Database collation - License - Configuration is pointing to the right application It is a bit bizarre that you got the ‘User Admin record exist’ message. Are you able to log into Axapta using Admn user ID? Also if possible could you post the Event Manager error message please. I haven’t got Axapta in front. But please make sure that the Admin user id is active by checking the UserInfo table via SQL Server. Good luck,

I have the license and configuration correct. For that I am sure. The Database collation of my MS SQL Server is Vietnamese_BIN. Is it wrong for Axapta??? I can log on to Axapta with the admin user name, blank password as usual. Thank you.

Khue, I have also faced a similar problem in bothe 3 tIer and 2Tier installation where the main menu sometimes fail to apper. This problem though is intermittent and loggin off and On again seems to solve the problem. Axapta version is 3.0 sp3. I think its some bug in AXAPTA where the main menu sometimes fails to paint . Cheers Amit Sood

I have it solved by changing the collation of Database. Is it any tricks in this selection???

Hi Khue, Glad you managed to resolve the problem [:)] Microsoft recommends case insensitive collation for Axapta. One of the reasons for problems similar to yours I think arises because of incorrect collation. BTW Microsoft is trying to remove this reliance on collation. Hopefully in future versions of Axapta (after 4.0) they should come across with some solution. Regards, Harish Mohanbabu

Thank you Harish. If version 4.0 supports UNICODE, then we don’t need to use the collation. Hope this will help.