Lanham Navision EDI Template Setup

The Mapping guide shows the General Tab with sample data of what is supposed to be there, but the file format tab has no info in the guide. Does anyone else use this Navision EDI solution & if so can you give me a sample of what goes in the fields. Thanks!

The file format tab contains formatting for the type of ASCII file you will be trading. If you are using Cleo’s Lexicom as your communication software with the VAN, you need to choose X12 delimited and accept the rest of the defaults. The interface file path is the path you use to get to your outbox. If you are using Lexicom, you do not need to put the word “Outbox” in the path. If you could tell me what type of communication software you are using with Navision, I can give you more information. Hope this helps.

I’m using Sterling Gentran Director. The file is delimited not fixed What I have setup so far for the EDI Template is: (File Format Tab) EDI S/W Vendor: Sterling File Format: Delimited Data Element Delimeter:* Segment Terminator:~ Dec. Segment Terminator:10 (not sure about this one it was automatically filled when I picked sterling but it might be for fixed only) ps what does “Dec.” stand for Decimal? not sure about the next ones - same reason as above) Seg ID Beg Pos: default 7 Seg ID Length: default 3 Trade Ptnr. Beg Pos: Default 57 Trade Ptnr. Length: Default 12 Am I in the ballpark? When i go to receive it doesn’t brong anything in. Do you use the debugger to find out where the problem is? Thanks for any help.

Are you using Generation 1 of Lanham’s EDI module? If so, they have a new release out which is much more reliable and does not require the use of GENTRAN. I highly recommend that you switch to it. Here’s what I remember about the version you are using: You need different templates for each document that differs in format. This includes import and export documents. This is much easier to set up in the new version. Leave Sterling as your SW Vendor. This will bring in the defaults for someone using Sterling. If you are receiving *'s as an element delimeter, then leave * in that field. However, if you are using something else, choose the proper symbol. The same applies with your terminator. ~ is the most popular. If you aren’t sure, ask for a sample from one of your trading partners. Everything else you have sounds correct. It is hard to say why it isn’t bringing anything in without seeing a sample of what you have. Here’s what I used for a sample import: Dec. Segment Terminator: 10 Seg. ID Beginning Position: 1 Seg. ID Length: 3 (this is standard) Trd Partner Begin Position: 7 Trade Partner Lenght: 12 (2 character qualifier + 20 character ID - standard). If you are really stuck, try contacting Lanham. They are very helpful!!

One more thing: if you don’t fill in the Last Internal Doc. Number, nothing will be imported. If this is your first import, enter something like this: ST00001 or replace ST with EDI (whatever makes you happy!)

I’m getting the message Document I_SLSORD not found for trading partner. It Does exist. my data begins with: BEG00SA*29043620031030 Is it a problem that it doesn’t have a “ST” segment that states that it is an 850?

Doesn’t the 850 begin with an ISA segment? If it doesn’t you won’t be able to import it. I’m not sure how you have GENTRAN set up, but it is possible that GENTRAN is stripping out the envelope information. If this is the case, you will need to find a way to get the entire 850, including the ISA, into Navision.

Thanks for all your help!!!

I don’t care what the “powers that be” say, EDI never made my life easier! :)~

I hear you! Were you able to import your order?

Problem was the partner only has a Print template so I wanted to take the file that’s saved in the transin directory & import it. But by bypassing an export template it seems it doesn’t include the isa line. I simply added it and it imported. Now I just have to set up the 3000 items and 50 ship to’s… YEA! or OUCH! I read that if an item number was imported and it’s not set up that the partners item numbers would be inserted in the item setup with the “unassigned” checkbox marked. Yet all i get is “Item # XXXXX does not exist” I never see the unassigned checkbox marked. Which increases the setup time.

My experience has always been that if I try to import an item that isn’t set up, I get an error. We try to make sure that all items are set up before creating a sales order. You can always recreate the sales order from the receive document, even if it errored out. Good luck!