Jet License Error with the current version

Our client have nav 5.0 and trying to connect with jet essentials 2011. Thier license only allows versions created before 1/17/2012. The current version of Jet was created on 02/22/2012 and cannot be used with the license. What version of jet essentials should I use?