Invalid data container type in AIF wizard

Dear All,

I am facing one issue in generation of document service by using AIF document service wizard. When I am creating a new document service using AIF wizard it is creating only table classes (Ax classes) including in query. At the time of creation of document class (Axd class), it stucks and throwing error of “Invalid data container type”, and then AIF service generation wizard not generating any document service and stops the generation.

The same error is also coming when I am updating any standard AIF document service which provided in ax 2012 as well as our newly created AIF document services.

Suddenly I got this issue, previously all things were working fine. I don’t know how to resolve this issue.

Please Help me regarding this issue.

Kind Regards,

Vijay Solanki.

Hi Vijay,

Welcome to DUG :slight_smile:

Try generating incremental CIL. Also make sure there are no compilation errors.

Last but not least, can you set up a break point at info class > add method; re-do the above exercise and tell us from where you are getting this error?

This Error is solved by using the below steps

1.Take Backup from Database Server.

Lets say Backup Files are DAX2012.bak,DAX2012Baseline.bak

2.Create New database from Dynamics AX 2012 Setup

Lets say New Database Names are DAX2012NEW,DAX2012NEWBaseLine

3.Restore the New Database(DAX2012) with our backup file(DAX2012.bak not DAX2012Baseline.bak)

4.Then Go To Administrative Tools → Server Configuration Manager → go to Data Base Connection

Server Name:ur Database Server Name



5.Click on Apply it will stop AOS Services and restart Services or else u can restart services manually

6.After all this close all things then Administrative Tools → Server Configuration Manager-> Configuration

->Manage->save configuration file with new name DAX2012NEW ,use this file.

7.We can get whole customizations with out any changes with out the error “Invalid Data Container”,now u can do all scenarios with AIF.

8.Although this might be a temporary solution it will suits in Development Environment,Because in Live it is different Scenario


Satish Kumar Kollati

Technical Consulatant

Hi Harish,

Thanks for your valuable reply. But I tried with Incremental CIL and also i have done the Full CIL and whole application compilation. But it didn’t work.

I am getting error in AxdDocument class. Let’s say i am updating Sales Order Service, so for that i m getting error in AxdSalesOrder class and method name is prepareForSave.

Please let me know if you require any more details.

Thanks again,

Vijay Solanki.

Hi Vijay,

Most likely the customisations around sales order area may be causing this problem. If there are any customisations please can you remove them and try again? Or better try in a vanilla environment first.

Also when you generated full CIL and whole application compilation, were there any error messages? Usually if there any any errors, these two steps should pinpoint to those errors.