Indirect costing

Hello,

I am practicing with the AX demo data, and I am trying to mirror our company’s BOMs and routes into AX so that I can see if our BOM calculations and AX’s BOM calculations match up. Some of our routes include machine work centers and human resource work centers. Currently at our company, we only calculate overhead costs for direct labor in our BOM costing, but AX keeps calculating it for all operations with runtimes/process quantities. We don’t want AX to calculate overhead for all the machines doing assembly work, just the human workers.

Any suggestions on how this can be done?

So in your costing sheet you have you indirects set. The indirects have a setup and you need to look at this and then the calcualtion type. As standard this is set to calculate on all process costs and material costs. However you can apply these to cost groups, so if your work centre has a direct labour cost group the indirect can be applied just to this group, and then the others are ignored.

I have assumed it is these and not the cost categories against the work centre.route because of the terminology you have used.

Thanks for your response, Adam.

I was playing around with the costing sheet and have had little luck. The direct labor is consumed on the route, and we have a run time cost category in place for it. However, for the run time cost category to apply to the route, its cost group must have a direct manufacturing cost group type. I have setup the direct labor process to have a different cost group than the machine work centers, with hopes of singling it out later when I am applying overhead.

Now for the costing sheet setup: I created a new cost group under the Indirect Cost node and associated our direct labor cost group with it. Then I created a new rate for that cost group. Next, I activated our overhead rate for an item within the specified cost group. When I try and validate the costing sheet, I get an error message saying I can’t create subnodes or something like that.

The problem I think I am having, is that my cost group type is direct manufacturing, when it should be indirect since this is an overhead calculation.

Am i going down the right path, and just missing something? Or have I been tackling this issue entirely the wrong way?

Thanks for the help!

HI Adam

there will be a confusion of terminology here. In the costing sheet under the indirect cost node you can create what it refers to as a cost group, this is the costing mechanism in the version. Then underneath this you define the actual indirect and here on the calculation tab you define the cost groups you want to apply this to. In your example this is set to “Direct Manufacturing” which is could be a node in the costing sheet itself. You may want to look at this and the subtype.

Create an indirect on the indirect type and then inside this when you set the surcharge or rate apply this to the acutal cost group at this level.

You would probably have to have a play with your indirect cost node, or post the actual error. It will be to do with what you have associated with it and how it is setup in the costing sheet.

you sound like you are on the right path, it just needs some tweaking at the lower indirect level. Hopefully the fact you maybe tying it to the costing sheet structure and not actual cost groups may help.

I was able to create a new cost group node and a rate node for overhead under the indirect cost portion of the costing sheet setup. Everything works perfectly for my BOM calculation if I use one of the default cost categories in AX for my direct labor operation. When I use that default cost category, its cost group will show up as one of my options in the basis for calculation as I am setting up the rate in the costing sheet. However, when I use the cost category that I created for my route operation, its cost group doesn’t show up as one of the possible codes to use as the basis for calculation.

How can I get the cost group I created to show up in the drop down list for the calculation basis? I tried right-clicking and going to main table form, but that is not an option…

Thanks for the help again!

So in the costing sheet you have created a new node for indirect costs? In this you have created a surcharge/rate and assigned this one to the cost group you have created for route operations?

So in the Indirect Group create a cost group called “ADAM” and assign this to your created cost group. Beneath this select a rate, and in the calculation tab set the cost group to “ADAM”

It is a difficult one to answer because it is more of a visual thing and playing with it.

This is how I have set things up:

My cost category for the operation process is “DSA Molding” which has a cost group of “LAB_DSA”
Then I created another cost group called “Mold OVH” and gave it an indirect cost group type.

My costing sheet setup looks like this:

-Indirect cost
-Direct Labor OH (a node I created as a cost group and assigned "Mold_OVH as its cost group)

  • DL OH Rate (other node I created, subtype set to Process)

When I try and add the calculation basis for DL OH Rate, LAB_DSA is not appearing in the drop-down list. Other cost groups were showing up, so when I changed my process category in the route operation to a category that used one of the appearing cost groups, my overhead would calculate properly in the BOM calculation.

Adam, I found my problem!

I had to include a cost group under the manufacturing node as well for the cost group I created. Then it was available to choose when I was selecting my calculation basis.

Thanks for your clarification on a few items and pacience!