Importing Warehouse Locations with Item Data

Hello, I am importing item data via the excel template. Everything works great except when I populate the InventItemLocation table with the InventLocationID and warehouse locations. When I do this the data comes in cleanly to the tables but the item is not visible from the item file. If anyone has successfully imported item data with Warehouse locations and can send me a sample template file that was used I would greatly appreciate it. Regards, Ted Haber

Hi Ted, I have been on leave so you may already have an answer to this question. You need to also update the InventTableModule table with the data for sales, inventory and purchase info. Basically you need to update three tables. InventTable InventTableModule InventItemLocation I hope this helps. Regrards Phil Dawson

Thanks for your reply Phil, it is the first I have received. I did populate all three of those tables and have successfully completed several imports. However, I am not able to import warehouse locations as I described in the prior message. Have you done any imports that included warehouse locations? regards, Ted Haber

Hi Ted, I am not sure which area of Axapta you are trying to update when you say “warehouse locations”. Is it the 1) From the item form Setup/Warehouse Items OR 2) Warehouse Management/Locations If it is 1) then what I described above should work. If it is 2) then you should look at populating the following table. WMSLocation You may also need to populate the WMSLocationSum table (not sure about this one but it is a data source on the form so it may be required) Regards Phil Dawson

I finally figured this out Phil. For some reason Axapat seems to require that the InventItemLocation table be populated without any warehouse or locations specified as the default. What I tried was to create a second record in InventItemLocation for each item to be imported and in this record add the warehouse and locations data. This has worked. When you look up the warehouse location from the item file you see two records, one blank and the other with the correct information, but from what I can tell this blank record is required. Thanks again for your responses, Ted Haber