Importing budgets

I’m having trouble importing budgets into Navision by Global Dimension. How does the Excel spreadsheet need to be organized to make this successful?

Any help would be appreciated.


When refer importing by Global Dimensions are you meaning filtering during import?

Create one budget line in Navision with the Dimensions required. Export it, there is your format.

I exported the budget into Excel with global dimension code set as a filter then populated the cells in Excel with the new budget numbers and tried to import that back into Navision. The numbers show up in the budget form, but when I specify the filter nothing shows up. It doesn’t appear that the imported numbers are associated with the dimension filter that I had set during the export.

Hi You should have a column defining the dimension. On the Options tab there is a field called Column Dimensions - did you specify your exported Dimension in here? When you enter new values you must make sure the Dimension column has an appropriate value set, so “you” associate the new value with a dimension. I can import and export without an issue, so it does work!

When I export, I have a filters tab and I have a filter set in there. It’s giving me the following message when I try to import:

“A filter has been used on the Company Code when the budget was exported. When a filter on a dimension has been used, a column with the same dimension must be present in the worksheet imported. The column in the worksheet must specify the dimension value codes the program should use when importing the budget.”

I have tried reimporting exactly what I exported and I have tried adding a column called “company filter” and copying the company value down the column in each cell adjacent to by GL account numbers. Neither way works for me. I’m missing something here.

That message is because you are not exporting it correctly.

You have an options tab on the export, select the dimension in the column dimensions box, you will then see a column in teh spreadsheet defining the dimension, Navision needs this column when importing with dimension filters.

Gotcha! Thanks. I’m a bit thick-headed sometimes, but I see it now.

Thanks for your help!

No problem at all, glad we got there!