I am facing problems while publishing Extensions.

Hi all,

I have Installed Business Central On Premise on my local system I have filled all information in Json file When I Publish Extension It shows Done but It could not publish extension.

I have done setup on Business Central Administrator also for run webclient after publish extension.

What is you error? You have not shown the error message here…

Depending on your server configuration the Json is valid

Error is not showing but when I press F5 the web Client is not Opening and also Extension is not creating

What is about crtrl+F5 and after created package?

Does it not show anything in either your Output or Debug windows? Try [Ctrl]+[Shift]+U and [Ctrl]+[Shift]+Y to display the messages?

Which VSCode version is it? I have seen issues after the latest update (came this week), after which it does not show the status to the debug window, and only says it’s created in the output window. It does display an error prompt after a timeout, but not saying what is wrong.

But using [Ctrl]+[F5], as suggested by red, will also show all messages in the output window.

Try F6 to show Error (newest VS code Build)

When I press F6 then shows error

Error: It is not possible to open the designer with ‘showMyCode’ set to false in the ‘app.json’ file. Also this error shows when I set

“showMyCode”: false,
“runtime”: “2.1”

Loads of information missing here…

In what object-id range did you put in your extension?

Did you add the ID-range into your app.json-file?

Try setting showMyCode to true.

While you are developing, when you are done, you can set “ShowMyCode” to false and use powershell to deploy your extension.

But why are you setting showmycode = false? If you are not developing your ovn IP, it will cause you more headache along the way.

I agree… Showmycode : false is really a bad idea