HY024 Database is Invalid or Cannot be Accessed - V5.0

Investigating why style sheets won’t work for some members of staff I have found the issue appears to be the above error. Users that have ‘super’ rights are still getting the above error when trying to perform certain tasks. I understand this is the software believing they do not have the appropriate rights but as they are set up as super users I don’t understand the issue. Is anyone able to give me some very simple and clear steps to check/resolve this? I am affectively set up the same as these users and I do not experience the issue.


Check these posts




Following link might help: http://dynamicsuser.net/blogs/nav_by_raj/archive/2009/10/02/changing-security-model-access-in-nav-on-sql.aspx

When database is in “Single User” mode and more than 1 session is tried then following error occurs:

Microsoft Dynamics NAV Classic

The following ODBC error occurred:

Error: [Microsoft][ODBC SQL Server Driver]Database is invalid or cannot be accessed
State ID: HY024


Resolution: Change the database access mode from “Single User” to “Multi user”, which can be done in three ways described earlier. Though the SQL query will change a little bit:

USE master


EXEC sp_dboption ‘DatabaseName’, ‘single user’, ‘FALSE’; // Note that True has now become FALSE.

Thank you for your suggestions, I’ve managed to locate the user setting on the SQL Server Management - the database was already set to ‘multi user’ rather than ‘single’.

Did you try with assigning permissions?

Hi, could you please tell me how to assign permissions? I’m not IT trained but have no back up for the system, so trying to muddle my way through - simple explanation please! Thank you.

You have to do that in SQL Server…better to do it with help of IT Administrator…

Sounds like you are having either Kerboros and / or active directory issues with your system.

In File / Database / Open, then the advanced tab, change the net type to Named Pipes and see it that helps (thats assuming that named pipes are enable on your sql server)

The net type is best left to Default, but you may be able to change it to get it working while you sort out the root cause

Unfortunately the user got an error message to say could not connect to the server as soon as she changed from ‘default’.

Hi, I have accessed the SQL management system previously, could you detail how to assign permissions and I will see whether I can follow the instructions, unfortunately I do not have support available currently so that is not an option. Thank you.

Select the User Properties. from Security–>Logins

Select Server Roles

check this now


Thank you for the link, I logged onto the server, onto SQL manager and went to security and logins, I didn’t see a list of users in that section that were indentifiable (e.g. windows logon names), however, to test I set all users list there to sysadmin permissions but this did not change anything for the user.