How to use postman to modify entity data

We have customized an entity, and now I want to modify the data of this entity through postman, but it always prompts me of errors in the picture, but when I modify the data in the customerV3 entity, it can be modified successfully. When modifying the custom The data in this entity will have the error in the picture above, can anyone help me, I would be very grateful

Hi ,

Can you see if you are able to read the data from your custom entity ?

Please make sure the entity is error free and check if the sync is completed successfully.




The synchronization has been completed, I can view the data in the entity, I can now add operations to this entity, but the above error will occur when modifying and deleting

Hi, I also encountered the same problem and hope to get your help

May I know the reason why you have added # in the field values.

My PATCH for my custom entity looks like‘abc’,CustomerAccountNumber=‘ae008’,CustomerLegalEntityId=‘abc’,AddressLocationId=‘1234’)?cross-company=true

We need to add cross-company if the dataAreaId which is used in postman is different from the default company of the user.

I suggest you do a GET operation first for the above Customer and then use the values returned from the response in the UPDATE operation. This is how I normally follow for a patch.

Let me know if you face further issues.


I tried. The value in () cannot contain #. When the value in my () does not contain #, it can be successful. Why? Is it because Poatman can’t recognize # this special character?

It’s not about Postman. It has a special meaning in URL in general.

Try using an escape character instead: %23.

Hello ,
%23 does not work like this, there will be an error, can you use other methods to replace the # character

Isn’t the problem in the underscore character you’ve added after test? Now you’re asking for #test_ instead of #test.

If that’s not the problem, note you need to escape it twice in some cases - I mean escaping % as well. E.g. # → %23 → %2523. Give it a try.

I dont think this error is because of %23.

Can you make sure the Customer which is used in the above query exists in the default company of the user in ‘Azure active directory Application’ set up.

Go to System administration → set up ->Azure active directoty application.

Check the default company for the user mapped in the above set up.

OData by default checks in this company for the parameters passed from postman.

If your customer exists in another company, make sure to use cross-company keyword .

I can be sure that it is caused by the escaping error. I tried to query the data without the character of #, and it was successful.


can you please share the values you are trying to pass for each filter ?

Now you can use the escape character to query data, I use %23, thank you very much for your help