how to show the image

I palce a Image control in the report section designer,which is link to a .bmp file, and it shows. After saving I run the report, but the picture didn’t show in the preview screen. why ? Thanks in advance.

Picture fields in a report a calcfields !! before you print the image, you must use calcfield().

Hi iammickey, Perhaps I didn’t describe my question clearly. I don’t intend to show a picture as BLOB in a field of a table. I link the image contorl directly to a external .bmp file and it shows on the report desinger section. I search the forum and find a post.pls link to Arthur Gedvillo mentioned as follow: Images stored in a BLOB has to be calculated with CALCFIELDS so in this just don’t calculate them. If they are linked directly to a file then you can only make two sections - first with and second without image. But I am not sure how to do next. Thanks for your kindly help.

Strange, I just tried it and got it the other way round - the image does not show in design mode, but when the report is run… How exactly did you create the control? Which properties did you set to what values?

Ok, there are two controls on Navision for showing images/pictures: Picturebox, takes the image from a BLOB field (you need using CALCFIELDS(Blobfield) to display the picture). Image, takes the image from a source file that has to be on .bmp format. The bmp resolution is 300 dpi and the file cannot be higher than 32K. The image is stored on the compiled navision object. If your image is not showing on the report try first increasing the size of the area you’ve set for the image control and check the visible property… :slight_smile:

Well, you could also use a PictureBox for external images. You have to provide a list of filenames in the BitmapList property and a “selection counter” in the SourceExpression property. If you leave the AutoCalcfield property at TRUE, you don’t need the CALCFIELDS. The 32K barrier applies here, too (you will get an error message in designer if your file is larger). So, which control did you use?

To Heinz,I use the image control. I found the real cause and did it. It is due to the bmp file name. The other settings are ok. The original file is image_1.bmp. It didn’t show. After changing to image1.bmp,it works. So strange… :frowning: Anyway,thank you,guys!