HELP! Overflow in decimal error

Please can somebody help me! I am getting an error on restoring a backup V3.10 falls over on table 37 as Overflow in Decimal. I know what the problem is but I need to restore the data - is there anyway of tricking the restore process to skip this table? Does anyone know of a way of just restoring particular tables? Thanks in advance - I’m desperate![:(]

Hello Peachey, Is the error occuring when the data is being restored into the database or is it happening when it is creating the keys? If it happens when the keys are being cut, you should be able to halt the restore before it gets to table 37 & access the data as it will exist, but just in primary key order. Otherwise, I’m afraid I don’t know…

Hi Ed No it doesn’t get as far as creating keys. I have treid restoring the objects changing the decimal fields to codes and then restoring the data seperately - but nothing doing. I only need the data out of tables 21 and 25! Thanks for your help anyway

Hi, There is no way to restore specific tables. If I understand correctly, you made a backup of the data, without the objects, right??? If so, at least, you know now that it’s always better to backup the application objects at the same time. You’ll have to find the source of the error and you will be able to solve the problem. Did you look at the DecimalPlaces property for those fields???

Hi It was a backup of the objects and data. There were 2 lines in the Sales Line table where there was a decimal field greater than 19 digits (just don’t ask me how that happened!) but this only became apparent when trying to restore this backup. Which is why it falls over when trying to restore Table 37. I thought that maybe if I restored the objects and tried to play with the deciaml places or field properties the data would restore into the table correctly. Have tried numebrous binary readers but even if you can get to read the table data you can’t make any sense of it. Thanks for your help

You can modify tables 21 and 25, deactivating all keys and press F12.

What about restoring to SQL DB. Setting to Full logging. And after an error playing with transaction log to try to reapply rollbacked bulk inserts ? Just an idea… Any chance to fix an error in original DB and do the backup again ? Probably the DB doesn’t exist anymore…

Hello Peachey, I came across this posting on the MiBuSo user forum: It looks like someone had the same problem and amanged to fix it.[:)] Hope this is of some help!

If you know the exact field, which is creating the problem in the sales line table, then make that field as Text of 80 in the database you are restoring (Assumption is that you get hold on the sales line table alone and can import saperately into this database before restore), I beleive, when you restore, backup it will take the object from the destination database, so this will restore that field as Text and once restore is done, you can later convert back this to decimal. Naveen Jain

Hi Naveen Jain, i think you’re wrong.


I beleive, when you restore, backup it will take the object from the destination database, so this will restore that field as Text

I have tested this and i got an error like “You cannot delete or change the field … before the value of the field is reduced to 0 or ‘’ (blank) in all records.” and the restore is not completed. the data are stored in tables upwards from 1000000003 Payment Terms. I used a native database, did you test it with a SQL database? br Josef Metz