Field is missing from the returned result set

Exception Message :The dataset ‘SalesInvoiceDS’ contains a definition for the Field ‘GiroType’. This field is missing from the returned result set from the data source.

[moved from title by moderator]

Hi All,

I try to debug the below method Underlined line shows the warning.

SRSReportRunPrinter - Class


private Array renderReportToFile(Filename _filename, SRSReportFileFormat _fileFormat)
Array files = this.parmSrsProxy().renderReportToFile(reportContract.parmReportPath(),
// write warnings to log.
this.displayReportErrors(); **----------- Error Warning Rised here ----------**
return files;

Then I Step into that method it calls SrsProxy class the below method. you can see the underlined line

public Array getReportWarnings()
Array reportWarnings = new Array(Types::String);
System.Collections.ArrayList warnings;
System.Collections.IEnumerator enumerator;
anytype warning;


reportingServicesExecutionInfo = reportingServicesProxy.get_ReportExecutionInfo();**--Error Raised--**
if (reportingServicesExecutionInfo != null)
warnings = reportingServicesExecutionInfo.get_ReportWarnings();

if (warnings != null)
enumerator = warnings.GetEnumerator();
while (enumerator.MoveNext())
// BP deviation documented
warning = CLRInterop::getAnyTypeForObject(enumerator.get_Current());
reportWarnings.value(reportWarnings.lastIndex() + 1, any2str(warning));
catch (Exception::CLRError)
// We must trap CLRError explicitly, to be able to retrieve the CLR exception later (using CLRInterop::getLastException() )

return reportWarnings;

In this method “**reportingServicesProxy.get_ReportExecutionInfo()” .**The reportingservicesproxy buffer is initialized in the SysProxy class

**Microsoft.Dynamics.AX.Framework.Reporting.Shared.Proxy     reportingServicesProxy;**

But it is a framework.How can I debug this? Please, anyone gives suggestions to come out of this.


Lakshmikanthan K

I’m not sure what you want to achieve by debugging the code. Shouldn’t you rather focus on the error message and GiroType field?

Do you see the GiroType field on the dataset (in visual studio)? If not try by refreshing the data set.

Hi, Drab

I have removed GiroType field in salesinvoice design but I didn’t removed this field in salesinvoiceds. My issue is the above warning message pop up in Aif exception grid.So,I tried to debug the code.

When I am posting salesinvoice there is no warning message popup in exception. but when I checked the useprintmanagement checkbox the warning message comes. What should i have to try.

Please advice.

Thanks ,

Lakshmikanthan K

Hi Kranthi,

I didn’t removed any field in salesinvoiceds. I just removed girotypefield in salesinvoice design. This changes was done 6 months before.At that time no exception came. but now this exception comes. what should i have to do?

Also i refreshed the dataset,

pls advice.


Lakshmikanthan K

This thread about the same problem provides a solution that you should try. It basically says that they’re missing an update.

Thank you for the quick reply drab.

We update that too.But still we are facing :frowning:

Hello, we are facing the same issue in AX 2012 R3 CU13, only on different fields. I found out that the corresponding SalesInvoiceDS fields in the SalesInvoiceTmp table (table used as datasource) were based on enum which had assigned a configuration key, which was not enabled. When I enabled the configuration key in AX > System Administration > Setup > Licensing > License configuration, the exception was not thrown anymore. The GiroType is also assigned to a configuration key and also enabled only for some countries. I guess that will be the case.

But enabling this configuration key is not a solution for us as we don’t want to have it enabled. So we consider reporting this as a bug to MS.

The KB installation is also not a solution because the KB applies to R3 CU12, so it should be included in the CU13.

We tried also the SSRS extension update using CU13 Update Installer but we could not update the Reporting extension because it was already installed. The option was greyed out.