F8 key not working

Does any body encounter F8 key not working problem? I found in Thinpad X240 laptop, F8 key is not working, but other functional key like F5, F1 working as normal… I have try to use a additional USB key board, but still not working. I am sure this is not account problem. Because this account can work fine in other model computer and no F8 key problem. Any comments would be appreciate…

Which NAV version are you using?

In NAV 2009 SP1 this happened with any journal that added to Home or any other button in the navigation pane; was ufficially not supported by MS and this possibility has been eliminated in NAV 2013.

Hello Daniele, thanks for your reply.

We are still using Navision 5.0 now. Normally F8 key can use to copy the previous journal line content to the next journal line. And this function is working fine in any other computer especially this Thinkpad X240 laptop. I am sure the keyboard is no problem and I even use the additional USB keyboard in this laptop, it is still not working.

So first I thought the funtional key in this computer may have conflict with navision. But when I try F1 to open the Navision help window, and F10 to open the filter, F5 to show the list. They all work fine except this F8 key…

Can you please try using it in other forms, like inserting lines in a purchase/sale order?