Error while previewing report

Hi every one,

i am trying to preview an report. on my system which is having windows 8.1 and it is working fine. but one of the system which is having windows 10, it is giving error

consider the following screen shot:

generally it comes when i click on preview button.

but the strange thing is this, it is coming randomly means some times reports generates successfully some time it is giving error.

can any body suggest me how can i solve this error.



When generating reports the system has to save the data in a temporary folder. The error message states clearly that you do not have write permission to that folder. My guess are that the user running the NAV client does not have full access to the computer? (Windows GROUP POLICIES are to strict/limitied).

If so, then an administrator has to change write permission to the folders - this is best done by uninstalling the client and then reinstall it.


Thanks for the Reply !!!

Today i re-install the NAV but still i am getting the same problem. do you have any idea how we can fix this error ?

The main issues is still the same… the user that runs the client does not have the proper access right to Dynamics NAV.

is the user not administrator of the computer?


Please give the permission on that particular path…

The path in the error message shows that it’s user Bhavy’s folder it needs access to read and write in. Normally that happens per default, as it is the users own folders. You could check what permission the user account has on the Windows 8.1 machine and compare it to the permissions on the Windows 10 machine. If in a domain, then your group policies may have been setup differently.

Have you tried to “RUN AS ADMINISTRATOR” when you start the NAV client, to see if the issue is still there?

Another thing you could try was also to uninstall and reinstall NAV from the client. Again with “run as admin”.

Which version of NAV is this, from the looks of it, then it looks like NAV 2009. Check if you are on the latest build. I do remember there was some issues with report preview in NAV 2009. This may have been fixed in one of the cumulative updates. That also applies if you are on other versions, check using the latest available update.

I have also moved this post, from the Developers forum, into the Technical forum, as it is not development related.

i checked the permissions to that folder and he is administrator but still error message is coming. the strange thing is this, it is not coming every time but it is coming 3 times out of every 6-7 clicks.

If the Error persists… then the administrator permission is not correct. - as Erik stands below, any group policies on the machine? And what specificially NAV versions and are you running ?

Hi Erik

Thanks for the reply !!!

i have tried all the suggestions provided by you.

  1. tried with “run as administrator”

  2. trid with uninstall and Re-Installation of NAV or even SQL also.

  3. i am using NAV2018 or NAV 2017. we are not using no previous version of nav than 2017

  4. I also checked the persmission of folder and compare the permission from window 8.1 with window 10.

but still the error is coming

Hi Sahil,

I can do it with remote access, you have to change the owner of the temp folder.

Go to Temp folder → Open properties of that folder—> Security TAB–> Click on Advance -->> locate change button near the owner —> serach for the user you are facing issues with & finally change the owner.

This should work

  • Amit

ping me on skype amit.aherkar if it doesnt work

thanks to all

it was the login user problem. we have logged with local user not from domain user. which gives the error for permissions.