#Error when run CustAgingReport

Hello everyone ,

when I run custAgingReport or vendAgingReport , I get #error Inside label.

I check the design of report , I think #error is linked to this expression :Format(Fields!Heading2DateValue.Value, Microsoft.Dynamics.Framework.Reports.BuiltInMethods.GetExtendedDataTypeFormat(“Transdate”, Parameters!AX_RenderingCulture.Value)). Any suggestion please ?!


Hi, did you find a solution for this? Im facing the same issue.

As a work-around I added the proxy user as a user to AX but hopefully you found something better in the mean time?

Regards, Hans

Did you tried these steps ? From MSDN https://technet.microsoft.com/en-us/library/gg731894.aspx

The report labels do not display, or the report shows label IDs, like Labels!@SYS24426 instead of the label values.

The SSRS Service Account password could be invalid.

1. From the Start menu, point to All Programs, click the SQL Server folder, click the Configuration Tools folder, and then click Reporting Services Configuration Manager.

1. In Reporting Services Configuration Manager click Connect and then click Service Account.

1. Set the password and then click Apply. The account and password should be the same as the Microsoft Dynamics AX proxy account. For more information, see Before you install the Reporting Services extensions.

1. Click the ServerName/MSSQLSERVER and then click Stop. Then click Start to restart the server. Always check with the SQL administrator and make sure no other users are connected to the server before you restart the server.

Checked out all of that but that was ok, finally found the solution on LCS:

KB2866407 , which is a kernel hotfix only, fixed it.