Error Running Analysis Report.

I’m getting an error everytime I run this Analysis Report under - Sales & Marketing - Analysis & Reporting - Analysis Reports. I am Exporting to Excel under Functions.

I’m picking Profit under the General Tab - All-Items - for the Date filter I have 01/01/09…12/31/09.

This is the error message I’m getting.

The sum of the values in the Sales Amount (Actual) field cannot be calculated because the filter contains question marks (?), asterisks (*), or “at” signs (@).

Filters: Analysis Area: Sales, Analysis View Code: ITEMS, Item No.:TSU*4818-B26, Item Ledger Entry Type:SaTable: Item Analysys View Entry

I checked both the Item table and the Item Ledger Entry table and there is no part number with TSU*4818-B26 in there.

There is a valid TSU-4818-B26 in there but not one with the asterisk.

Thanks in advance,


My first step would be to delete the zup file.

Hi Greg,

Did the part no. ever esist?

To me it look like its on the item analysis view entry table. To rebuild the view entry - change one of the dimension code on the Item Analysis View Card. You should be prompted to delete the entries and select yes. Then change back the dimension code and hit the update button.

I’ll try that Dave.

The part is a valid part number.

I tried deleting the Zup file but that didn’t help.

Hi Greg,

Sorry a typo - did the part with the * ever exist? if so it was stored the the item analysis view

Yep rebuild the analysis view from scratch. After that it would be a case of trying to de-bug it, because these first two steps deal with what teh end user controls.

The part number with the * is not in the Item Analysis View table. The valid part TSU-4818-B26 is in there twice.

The report runs about 10 minutes before bombing off and locking up my computer…

Did you rebuild?

Did you create a new one with the same parameters and get the same message?

Sorry for the delay but everytime I run the report it ties my computer up for 10 minutes and get’s near the end before bombing off.

I tried deleting the entry and that didn’t help.

I’m not sure how to debug.

I’ll be out of town for several days before I get a chance to look futher into this.



It is fixed now. There was a bad entry for this part in the Analysis Line (7114) table that I deleted and now it works good.

Thanks for everyone’s help.


I’m happy to hear that Greg, but if there was a bad entry in that line, then doesn’t that mean that you never did a full rebuild of the analysis?


How do you check for a rebuild of the Analysis?

I just made sure it worked without bombing off. I’m not even sure what the report does.



Hi Greg,

This is the standard way but you can delete the entries and update the last entry No. to Zero and then update. It would be interesting to find out if the entry re-appears when the view is re-built and investigate if there is a problem elsewhere.

Hi Greg,

If you feel that one of the replies answered your question, then please click on the verify solution button next to the post. This way we know that the thread is closed and it’s your way to credit the person who helped you.