Error: localhost refused to connect

Hi All,

I am trying to implement NavUserPassword for Business Central 14. I followed the following post: and it is working for the Windows Client. However, i keep getting the the below error when i tried launching the web client. I did everything i needed to do according to the Chris Blog post and This

Hmmm… can’t reach this page

localhost refused to connect.


Anyone know why i am getting this error and can’t display the logging page?


Normally it’s straight ahead, just as described in the blog post, so I’m sure you’re missing on step?

When it’s the Windows client, then you may also need to change the ClientUserSettings.config (or delete it, then the server will create a new).

I thought so too. It should be straightforward just like in the blog post. The Windows Client is working as expected, it is just the web client that is throwing this error. Do you know which step i might have missed? Erik.

Just to be sure. Did you change the servicetier to NavUserPassword?

In order to get it to work there are five issues

  1. Either you have to create a new servicetier or change the existing ones

  2. You have to change ClientUserSettings.Config (if you want to test that the user works)

  3. Web.Config file needs to be changed to handle NavUserPassword

  4. You have to add a user (as stated in the links) - And remember sometimes that user needs to be added as DB-owner on SQL.

  5. You need to be sure that the Servicetier you change/add cannot run on as networkserviceuser you have to add a “real” user.

Hi Palle,

I have changed the servicetier to NavUserPassword. I have also changed ClientUserSettings.Config (). I have This: . Should the value be blank or needs setting? If needs setting, what should be their (Localhost or computer name?). How do you change Web.Config to handle NavUserPassword?

Below is my web.config file:

<?xml version="1.0" encoding="utf-8"?>

I have already added a User.