Error installing GP 2015

I am tring to install GP 2015 on a new Win 2k16 Citrix server. I am getting the following error and cant get this installed. Anyone know a work around?

System.InvalidOperationException: Operation is not valid due to the current state of the objecdt.
TypeFromImageType(DeploymentImage deploymentImage)
at Microsoft.Dynamics.GP.Deployment.UX.EntryPoint.Run()


Hi Frank,
I’m going to try to help you as best as I can from my long experience in GP installation…
Did you fill all the prerequisites for GP (Dexterity run-time libs & all)? From the error message you captured, it looks like you’re trying to install GP from a Deployment package? or is that the regular GP Setup?
When does this pop-up ? right after you run the Setup.EXE from the GP image or after the main installation panel shows up and allows for various options to select from ?
Did you check the Windows Event logs to see if it returns more details ?

1 Like

Yes i ran this by using the setup installer. This error come up immediatley. I dont really see anything relevant in the Event Viewer.

I assume all the pre reqs would install during this setup.

Hi Frank,
You may have already solved the problem, but in case not, I found this old post on the Microsoft community forum. The response suggests that your problem may be a corrupted installation package. If you haven’t, try redownloading GP 2015 from here.

Hope this helps!