ERROR: AX.Framework.Services.Metadata .Contract.DataFieldMetadata

Hi All,

I’ve added 3 columns in the “SalesInvoiceTmp” table after this customization in the table my sales invoice report renders no output on the screen even my temp table is getting inserted with proper records.

So I just decided to revert my changes on the table. Deleted the 3 columns from the table after this I’m getting the error(Shown below) on the Visual Studio when I tried to refresh the Dataset or while attempted to edit the data set of the report.


I’ve done the following step before refreshing the data set of the report.

  1. Sync the data dictonary.

  2. Generated incremental & Full CIL(Removed the files from Xppil folder).

  3. Restore & compiled(Compile Forward) the entire class related to the report and some framework class like SysDictFieldMetadata, etc… (Just a greed to fix this issue anyhow).

4.Stopped the both servers AX, Sql Server & removed the .AUC file from the appdata for the user.

  1. Reset the AX user data and refresh the AOT Elements.

  2. Removed the fields in the design of the report where the 3 columns were occupied.


Same error popping up… Any help on this would greatly appreciated. Thanks.

It seems that your report still refers to a field that doesn’t exist anymore in AX. Aren’t you still selecting the field in your data set?

Thanks for the reply Martin.

Sorry. I can not able to select any columns in the DataSet because when I try to refresh the Dataset then the pictured error is throwing.

Hi Martin thanks for your help on this “I see there’s a progress on this issue”.

In the mean time I was managed to fix the issue by removing the .dll file (SalesInvoiceReport.BusinessLogic.dll) from “C:\Users\donyMathew\AppData\Local\Temp\3\SalesInvoiceReport.BusinessLogic”.

I really do not know whether this will spoil me report in feature ? but now the SalesInvoice report is not rendering the output (Attached the image below). The temporary table “SalesInvoiceTmp” contains the correct records.

Can you please suggest me some thing on this. ?


Same error I’m fetching:


You are issue resolved or not?

because i’m getting same issue whenever adding my data set .please help me?


I’m resolved this issue,

Please go on your temtable ,this table which one field are found there is no EDT Relation to another table

kindly check.