Error 1213 in module 19 - Database Crash

We currently have a client that has a databse structure error. We have isolated the problem down to the item ledger and found that one transaction is unable to be read. You can not even show this on the screen. The problem is that we can not do a backup to restore to a new database. We can not delete the faulty record or the table because it contains records. Because the client does not have a backup we are exporting the data to a new database. This will take days and if anyone has any ideas on how to get rid of this record or table it would be apprieciated as it would save time. We have tried, changing the key, backing up in read only, deleting all other records then optimizeing with no success. The error seems to be in the primary key. Thanks ---------------------------------------------- Moved from “NF - Technical Forum” by moderator Edited by - rmotzer on 2001 Mar 29 00:32:28

I don’t know this error, but my experience from other errors have been to: 1. Move all other records to another table/company 2. Delete the last record with DELETEALL 3. Move the rest of the records back.

We had tried the DELETEALL with no success. In the end we were able to copy all data to another company except the record in the item ledger. We had an older backup with this record so we inserted it with a dataport. We then did a backup, created a new database and restored. The problem seems to have been caused by Memory leakage in conjunction with an incorrect pagefile size. We used a report that was created by Mr. Gayer Rene (Copymandant) which we found on This created the object that would copy all the data from all tables to the new company. We modified the new object to not copy the faulty record.Great object. Thanks for your input. Tim