Error 1067 on Navision Service

Hello I have several Navision 2.60 databases on a Windows 2000 server. I can no longer run any of them and have found that although the service attached to each database is set to automatic the service is not started. If I try to start the service I get the message “Could not start Financials Server XXXXX service on local computer. Error 1067 The process terminated unexpectedly.” I think this may be due to the amount of programs and data on the server - because it is overloaded, but does anyone else have any other ideas? Cheers Steve

Could it be that the user that the services are running as has changed the password (Could be if they are not running as SystemAccount)? Or are You running with a developers license that has expired? //Lars

Hmmm … well, I have no experience with Win2000, but in NT, this Error occurs if the HOSTS and SERVICES-Files are not configured properly! Maybe there’s something similar!? Regards, Jörg Joerg A. Stryk Apollo-Optik, IT/ERP

Hi - Thanks for both the responses Lars - There are no password alterations. The license idea coould be true, but I have changed them from the workstation, in the database, but cannot then start the service on the server. Our developers licenses did expire a couple of weeks ago. That said there are a couple of true customer licenses on the server that should therefore work and do not. Joerg - The hosts and services files are set up correctly, I think the problem maybe around the license issue Steve

Hello Steve You say that You have change license from a Navision Client. That does not afect the server, only the client until You restart it. To change license file on the server You’ll have to copy the license file into the folder where the server is installed and name the license file “fin.flf” //Lars

Steven, I have just had the “Error 1067 The process terminated unexpectedly” when trying to start a NAS-SQL 3.60 service on an NT server. Did you have a resolution to this issue that might be relevant in my case. I have set up all of the NAS parameters and the NAS service is set to use the domain administrator account (for now!!) which is also defined as SQL database login and a windows user in the target database. This database also has the required modifications in codeunit 1. I suspect the NAS-SQL service is not even getting as far as attempting to connect to the database when it fails as there is no message in the application log. I would appreciate any light you might be able shed on this. Thanks, Chris.

Hi Chris We did the following (not me I hasten to add - a more technical colleague [:D]) From the dos prompt we changed into the navision server directory Then ran the uninstall command for the service. server servername=nnnnnn uninstallassservice This will remove the service Then run the command to install the service Type server servername=ntserver, nettype=tcp, cache=12288, commitcache=yes, database=e:\navision financials\database.fdb, installasservice. Replace ntserver with the service name, set cache as appropriate and db path as appropriate In essence replace ntserver with your service name. Then you must start the service either netstart service name from the dos prompt or from the services option in w2k. We think this was down to the service not being installed correctly for some reason. In summary 1) uninstall 2) reinstall service using command line 3) start service I hope this helps [:D]

quote:


Originally posted by SBWEAVER
Hello If I try to start the service I get the message “Could not start Financials Server XXXXX service on local computer. Error 1067 The process terminated unexpectedly.”


Today i was having the same error on a customer and it was caused by the license file. The license file was sent to that customer as attachment and the customer received it on a hotmail e-mail account, so he saved it onto the hard drive and install it… the error appeared. It was all because hotmail corrupted the file (considered it as a text file or something similar) and the problem was solved by sending the license by e-mail again but previously zipped… the zip file went through hotmail fine and the server restarted again without error. Regards,

In case anybody else finds this posting with similar problems my experiences on this problem are as follows… Navision have released a number of builds of the SQL version of Application Server. Whereas the early versions were happy to connect to a SQL Server v7 it seems later ones are not and will only run with SQL Server 2000. This only became apparent when you attempt to set up the service entirely through the command line as Steven advised above and not using the MMC. Under these conditions you actually get a sensible message advising you of the problem and not just the “Error 1067”. I am contacting my NTR for advice on NAS version dependencies and also to source the earlier version I need for my customer running SQL server v7. Chris.

Chris, SQL Server 7 support was removed from version 3.01, i.e. from Attain onwards. It is only supported by Financials up to 2.60x. This applies to the client and the application server.