Dynamics Navision not sending data to Excel 365 with NAV add-in

Hi All,

I have a NAV 2013 that has been humming along for 7 years without any issues. Until now.

The situation is we are running with remote access using Microsoft’s remote gateway. From the NAV scenario, it is running fine.

Starting this month, our Finance team is unable to use the ‘Send to Excel’ button. Here is what happens:

-When the button is pressed, Excel opens, displays the correct window header, but never populates the data into the spreadsheet.

-If you try 'Print to Excel;, it does the same thing.

-If the button 'Send to Excel is used, the header is just a normal new spreadsheet header but the data populates.

Excel does have the Microsoft Dynamics NAV add-ins active.

In troubleshooting, I disabled the add-in and tried the 'Send to Excel button. It still opens Excel the same way with no data in the spreadsheet. If I go to Options/Add-ins and add the NAV add-in, Excel throws a fatal and I receive the “Microsoft Excel has stopped working” message.

This had worked last month. The only difference is Excel was updated to version 12527.20988. As we run Office 365, this update occurred automatically.

So the question is has anyone else experienced this and has a solution been found?

Any insight would be greatly appreciated.

We have experienced this a few times and does seem to strike intermittently so could be an Office update that ‘breaks’ it somehow.

On your installation media, look for the file Microsoft.Dynamics.Nav.ExcelAddin.vsto (probably in folder NAV.7.1.xxxxx.xx.Full\RoleTailoredClient\program files\Microsoft Dynamics NAV\71\RoleTailored Client) and run that on affected users’ computers (probably requires Admin rights).

Hope that helps


Hi Paul,

Thank you for the response. I am looking at the ‘RoleTailored Client’ (70) folder of the “user’s” computer. (As this is a remote gateway session host, the user’s session is virtual.)

I see three files for the ExcelAddin: .dll, .manifest, .vsto. Are you suggesting one of the files has now become corrupt or is it the regkey for ExcelAddin has become corrupt?

This configuration has been stable for (it looks like from the dates of the files) 6 years. I don’t want to start re-installing files without knowing what is being affected.

Your response is greatly appreciated.


Not necessarily corrupt, I’m not sure what the issue is, possibly a registry key or something. The .vsto file is a Visual Studio Tools for Office add-in installer. That’s the one you (hopefully) need. It would have been run when NAV was first installed (if the Excel Add-in was selected as must have been the case), but somehow occasionally something does seem to go wrong. Rather than totally reinstall the whole NAV client, just installing that component again has solved the problem for us a fair number of times. Most recently 2 or 3 months ago in my case.

Hi Paul,

Sorry for the confusion.

Your solution did work. It appears the Office update broke some permissions (as the user who installed Office is no longer with the organization and their account has been removed.). We think it broke the regkeys for the addin.

The reinstall of the addin (running .vsto) worked.

Thank you for sharing the solution.