DLL error in AX 2012 R3


We are trying to install a hotfix in AX 2012 R3 CU9. While running the upgrade checklist, during the compile step, we are receiving errors of a DLL file. We tried reloading the DLL, deleting the XppIL folder & generating CIL again. Nothing works. We don’t have the same issue on another server running same version of AX without the hotfix. We restored the database backup from before we installed the hotfix and still we are not able to compile. How to resolve this error?

Check the code again…


Do you see those DLL’s on client and server bin’s.

We checked it. It is on sys layer.

Yes. That DLL is present in both client & server bins.

What kind of hotfix is that? I think your binaries are not updated properly.

KB 3077681. It is for issue of License Count Report.

we ran into issue like this doing full AOT compilation and Full CIL solved the issue. Note: we have tried done the compilation like 5 times then its compiled properly.

We performed parallel compile & CIL 4-5 times & then the issue was resolved on it’s own.