Deadlock upon SQL synchronization AX 2012

Hi Guys,

Please help me on this one. Have you encountered deadlocking issue upon sql sychronization in AX 2012? It happens when I am performing SQL synchronization then it hangs and stops progressing. When I check the Activity Monitor in SQL Server Management Studio after I force closed the AX client, It locks upon insertion command in the Dimension Hierarchy table. Can you please give me some advice regarding this issue? I already tried to wait for almost 2 days on synchronization but it still hanging. Thanks in advance.

It sounds more like a blocking than a deadlock. If two processes deadlocks each other, SQL Server detects such a situation and rolls one of the transactions back. Your situation seems different - process A waits for resources held by process B, but B doesn’t wait for A.

You should look at what process / query holds the lock or maybe simply kill the process holding the lock.

Thanks for your reply Martin! I tried to kill the process which is blocked in the activity monitor but still, the issue still exist. Does the batch job process in AX involves here?

Which batch are you talking about? I thought you were synchronizing database.

Hi Martin, Yes I am in synchronization issue. however, I am thinking that some batch job process running in AX which trigger the dimension hierarchy table is the cause of the blocking. Here is the screenshot of the activity monitor in my SQL

It’s executed by some process and the process may be a batch job, but I’m unable to tell you what’s running in your system.