Dataport Question

Is there any way at all to tell a dataport to include all fields, without having to pick each one individually? I have a table with 90 + fields that I want to export, and I am not looking forward to picking each field inside that little form. Is there a Dataport property setting for this? Any help would be greatly appreciated Thanks

In the dataport fields (From View, Dataport Fields), you come up to a blank list where normally you can lookup by line… Show the Field Menu (From the Toolbar), hit Ctrl-A to select them all and click back on the blank list from above. This may be confusing to explain but simple to do [;)]

There is no property that I know of. However, you can paste the fields in one go. 1) Open the “Dataports Fields” window. 2) Open the “Field Menu” window. 3) Highlight all in the “Field Menu” window. 4) Move to the “Dataports Fields” window. 5) Move the cursor to the SourceExpr field and you should be prompted with a question asking if you want to append all fields. Press “Yes”.

Dont forget to exclude the flow field. My suggestion, is to write the dataport in excel, its much easier.

Tnx to all - it worked. Do I really need to exclude flow fields? I never have in the past

It just depends which flow fields, just try on a test db first. By the way, if this is related to your SQL error posting, then a Dataport should also give the same error and crash. If this is the case, I would :- create a copy of the customer table. remove all code, and disable all keys (except the primary). Then change No. to type text 20. Then go to SQL, and copy all the records to the new table. Then deltealll(false) on the customer table, then write a report to move the data back, with the command Cust.“No.” := uppercase(custcopy.“no.”);

For export you can hold flow fields but in case of import you get an error

my assuption was that he was going to re-import the data, thus my comment to exclude them.

Both export and import of flowfields works fine. Blobfields and disabled fields must be excluded, though.

That was my impression was that BLOB fields were the issue. I have reimported Flow Fields and they are not a problem, I think Navision simply ignores the imported value

There was definitely an issue in earlier versions, but it may be way back, maybe 1.30, out of habit, I just always leave the flowfields out of imports. In any case I don’t like dataports, I prefer the screw driver and pliers method (code). [:)]

I just tried it with flowfields : Without an explicit CALCFIELDS() in the OnBeforeExport trigger the export does not work in Nav 2.01 and in Nav 2.60. All fields are set to 0.