Damaged Table with included columns

Hi all,
yesterday i was creating indexes with included columns.

I added several columns (20) and after that wanted to mark several columns and change the property to Included Column.

AX crashed before i could make the changes and now or DEV system is damaged. AX tries to create 20 KEY columns in SQL Server wich is not possible.

Everytime i click the table the AOS crashes. So i can’t make changes back.

Any suggestion would be great!

Thanks in advance,

Update: found a hint here, but it was not possible to delete the table. BTW the table exists in the sys layer - confusing…

The last resort is, I mean, if you have tried everything else still no luck, then if it’s a DEV box, you can refresh the box from another DEV box. Since you are AX 2012 R2, once the transaction database and modelstore database are restored, do the full system compile, sync data, full CIL. If you use version control, sync your code with depot as well. You should be good to go.

Thanks Kwen,
seems the only solution. Thanks for sharing.


No problem, Peters, hope it helps~