Customer "Special Price" Currency Code

Morning,

This is a bit of a weird one - I have tried to search to see if anyone has had this issue before, but I can’t see anything…

So,

Within our BC setup all our items have a price, but there’s also a trade price, wholesale price etc etc, so customers can be added to pricing groups or have their own set of prices assigned to their customer card.

The thing is, some of our “stockist” customers are not VAT registered and are perhaps small shops, I know this is irrelevant because we still charge them VAT, however when we print a price list for them they don’t want to have to calculate the VAT, so to make it easier for them we thought we could print a list including VAT.

So I used one customer as an example, we have custom fields on item cards so we can filter what products are “assigned” to what customers, basically so they don’t get 16,000 items on a price list, just the items they buy. So I pull up the customer card, go to special prices, enter the product etc, and the price, there is no option here to say whether the price is inc or exc VAT. However, when you choose the edit the page in excel, there is a column that says “price includes VAT” then the typical true or false answer.

They are all set to false, so I thought oh great, I changed them to true, hit publish, and here come the error messages.

Details: A row update in data set Sales_Prices_Excel was not published. Error message: ‘No Currency within the filter ‘’. CorrelationId: 19b8ea43-54ee-4caa-aaf0-8bf216577603.’

I don’t understand, we are in the UK so only use GBP, however GBP is not an option in BC and I know you’re not “supposed” to add an option for it as it’s the base currency.

So why is it asking for a currency all of a sudden, and how can I get round it?
Any help would be greatly appreciated !!

Thanks,
Gareth

Actually there is a column for this field, but by default it is hidden. You can add it through the Personalize option (if You are not familiar with that, You can easily google it - how to add/remove columns).
Also there is a column - Currency Code. Might be that You are trying to import not an empty value here.