Currency Conversion is not working for Vendor Invoice

Hi All,

I have created and posted vendor invoice.The currency conversion is not applied to only one record in voucher transactions for other records it is working perfectly…Please see the below screenshot.

Please suggest me the possibilities to solve this issue…

Thanks in Advance…

Don’t see any DEV requirement. Moved to User forum.

Have you checked the exchange rate on that date and exchange rate on related transactions?

Currency coversion is not working for the charges code value…

Can you elaborate?

Hi Kranthi,
If I uncheck the Execute business operations in CIL Currency conversion is working correctly…if it is checked then the currency conversion is not working(as above screen shot)…Please suggest me the possibilites to solve this issue…?

Try by running FULL CIL. (follow the steps in the below link)…/

Hi Kranthi,
The result is same afer performing full CIL using the steps in above link…

In that case, the above statement doesn’t make sense.

To confirm, try debugging with/without that check mark. (with check mark you may have to use the visual studio debugger).

Can you tell me the classes related to it(Voucher and currency conversion process)…?(PurchInvoiceJounalCreate)

\Classes\PurchInvoiceJournalPost, look at post* methods.

Hi Kranthi,
I couldn’t able to debug in visual studio…I have added breakpoints to \Classes\PurchInvoiceJournalPost post* methods, attached the process( AX32Serv.exe)…
But I got one error while performing incremental CIL…
Will Incremental CIL error affects VS debugging…?

Could you please provide stack trace for this if possible…?
The debugger was not hitting in PurchInvoiceJournalPost post* methods and CurrencyExchangeHelper while posting invoice.

Any suggestions…?

have you tired by adding break to \Classes\CurrencyExchangeHelper\calculate?

Yes.But the debugger is not hitting…

Also I have overrided the insert method of generaljournalentry and generaljournalaccountentry table and addded the breakpoints…Still the debugger is not hitting

Any suggestions please…

Try to debug using AX debugger and find where the currency conversion happening for mark up.

Then compare those methods/code with the IL code in XppIL folder.

Thanks for your reply…
Can you please confirm the following…?
I ran Full CIL with the necessary steps,So the Code in CIL should be upto date.So the currency conversion shouldn’t work in both scenarios right…?
Why it is working when the CIL is off(uncheck the Execute business operations)…?
Please suggest me on this?

If it is working in non IL scenario, then it should also work IL - considering your IL code is upto date.
Do you have customization’s around this area? Have you tried the same in a standard environment?
Have you identified the code responsible for it (or) code triggering the conversion?