Could not create a new general ledger journal

Dear Friends,

I need your kind help. I could not create a new general ledger journal. The last journal number is 009922-00. While selecting for a new line the following error message appears.

“Cannot create a record in Ledger Journal Table (Ledger Journal Table) Name; GJour, General Journal Record already exists.”

Highly appreicate your kind help.

Thanks & best regards


In the number sequence for the journal you can reset the next number - depends what number it is failing on, how this is set, how you are creating the journal and what caused the issue in the first place.

Thanks for your quick response.

We were in the process of passing various entries as required and the last journal # 009921-00 was posted yesterday. This morning when I selected a new line, then this erros appeared.

It has noted in the begining that when opening balances posted the default journal number was 009922-00. By sequence a new journal number should be 009923 but it does not come. Your advice is highly appreciated, Thanks, Sajevan

How is the number sequence configured for the journal?

How to find out this. I haven’t configured anything.

Go to the journal name of the journal you are using by right mouse clicking and going to main table. The journal setup will tell you how the journal has been configured. You can also find this under setup and journals in GL. You need to verify the settings here. You also need to look at the assigned voucher series. Right mouse click and go to main table and verify the settings here - is it set to manual, is it stopped, what is the next number defined etc etc.

If you have no experience why are you not contacting your partner?

How you have imported opening Balances?

Manually change the next number to 23.

Go to Basic > Setup > Number Sequences > select particular number sequence > click on List button > see there any data is available and if its there delete those lines and come back and try to create journal lines.

We have corrected manually. Thanks for your advice.

Thank you. corrected manually. thank you for your concern

Can you please vcerify one or more of the solutions. Telling someone searching the forum with a similar question that it was fixed “manually” is not helpful - please help the future posters by telling them what you actually did.


You are right , I have done the following steps to solve this issue.

Under Basic ----- > Setup ----> Number Sequence ----> Number Sequences------> Number Sequence code----- select Number Sequence code (in my case its was Gene_5) then go to General tab… Under Number Allocation changed NEXT: number as 9953.

I am sorry for not posting this earlier and thanks for correcting me.

Best regards


Thank you for the update - future posters will hopefully beenfit from it [:D]

Where is basic??? i am not getting proper way please help me,

That should be AX 2009.

If you are using AX 2012, you can find the same in Organization administration → Common → Number sequences.

Please be more specific when you ask for a question.