costing: cost group are missing for routes if multiple levels

Hi there,

In the result of my cost calculation, cost groups for operations between Raw Mat and Semi Finished are missing.

Let’s take an example: I have Raw Mat, Semi-Finished and Finished Goods. Between these levels, I have BOM and Routes. In the result of my cost calculation for my Finished Good item, I have no cost groups from Route used to transform RawMat to Semi Finished. I have for sure cost groups from operation coming from the route between SF and Finished Good. It seems that only costs from Routes for the previous level of my item is shown, of course I have all materials costs. Only some costs based on time/operation are missing.

And if I have a look on the cost of my SF item, I can see all cost groups … even those wich are missing on my FG item cost.

Could you point me where I have to dig to find a solution?



On what basis are you running the calculation on the top level and how is the costing version configured, not to mention the costing method in use!


Costing version : planned

Cost price model: cost group

Explosion mode : multi level

Fallback : active

I repeat: I can see all material costs from the lower to the upper level. But only the last level for operation costs.

thanks and regards,


I will presume cost group was a error and you meant calculation group.

It works fine for me, all levels shown with all routings and indirects.

Are you trying on demo data or your own?

How is the calculation group configured as you are using it?

Is the BOM line visible with no routine, or is it aactually not visible because it has been flagged to be removed from the calculation?

Are there any modifications?

  1. You’re right : calculation group.

  2. I tried on my own and demo data. It used to work on my demo, but I can’t reproduce it on a new data base.

  3. calculation group :

I tried both: a) without a calc group assigned on SemiFinished and Finished items.b) And with a calc group set up as : item cost price, “stop explosion” not checked.

The BOM is visible in my hierarchical tree with no operation, the only routing I can see is on the last level. If I have a look on my SF, I can see this routing.

On all levels, I have my indirects costs (surcharge and rate).

I really don’t understand where is the parameter which control that feature.

More or less related to “explosion mode” which is set as “multilevel” on my DB.


So on the calculation for the finished product you see the indirect costs and the components of the sub-BOM and the sub-BOM line but no route. I presume the indirects are not route based. You run the calculation on a site - is the route active and approved at the site?


Route is active and approuved per site.

Indirect Rate (subtype=process) are missing too when assigned to a sub-route. Those assigned to the last level are visible.

Indirect Rate (subtype=level) are visible BOM, sub-BOM.

No clue?

thanks and regards,


The general tab of the routing group against the operations in the route not showing - how is it set?


A workcenter, Qty WC :1, load : 100, property: empty, route group: 10 (allow setup time, allow run time, all activated on setup tab), route type: standard.

On setup tab: a category for setup, a category for run time, nothing in Qty category.

But, I can see route when I query that semi finished item cost !

Something prevent me to inherit routing cost from upper level.



You did not confirm the setup tab of the routing group - the estimattion and costing flags, unless you mean the allowed.

Can I presume you manually created this data?

However if you can run it at one level and it works for the lower level this would imply your costing version or calculation explosion principle is not set to multi-level, but you have confirmed it is. It seems to me the calculation routine is stuck on a single level calculation, so stop explosion flags could also be set - I would concentrate on this if I were you. I would also create a brand new multi-level item manually with a one item bom and one step routing and see if it works.


I succeed to get it work on a standard version. I have problem on a version with Process add-in. Customer support told me to install the most recent BUP layer update for the Process Industries module.

My IT guys are working on it. I’ll let you know the end of that story.


I would mention the Process add-on next time, this does create issues in various places depending upon the version. I was obviously testing it in relation to the standard product. [:D]