Cost Adjustment Error in 3.60

We recently upgraded Navision Attain US to 3.60, and now whenever we try to run the ‘Adjust Cost - Item Entries’ periodic activity, we get an error. I was wondering if somebody else had encountered this error, and if there was a fix and/or workaround that could work. After debugging the problem a bit, it turns out that they changed the Inventory Adjustment process completely, while before they used to populate the Adjusted Cost and Cost Posted to G/L fields in the Item Application Entry table, now NA is creating Item Journal Lines and posting them. The error occurs when the process is trying to ‘adjust’ a transfer entry (Item Ledger Entry). When it tries to post the corresponding Item Journal Line, it is filling the Entry Type as Transfer, but leaving the New Location Code empty, which is later checked by the post routine, and causing the error.

I’m using Navision 3.60 MY and I also encounter this problem. Have you found the solution to it ? Thanks in advance.

Hi, Have you applied HOTFIX 2 and 7 for Navisoin 3.6?

Hi, I have run in to this problem to and found this on the partnerguide (DK-68-882-KEH7). Try unchecking “Location Mandatory” in your inventory setup before running adjust cost. Regards Magnus

Got it !! :wink: Thanks.

How about blocked Items? If Item has unAdjusted entries. I got error because Navision tried to post item journal lines.


Originally posted by ainukovarnjemties
How about blocked Items? If Item has unAdjusted entries. I got error because Navision tried to post item journal lines.

No, blocked items are not in the picture. However you are correct, the error occurs when Navision tries to post the item journal lines. About the “Location Mandatory” flag, my only concern is that NA is trying to transfer stock from one location to ‘no location’. In our case, I modified the code to fill the “New Location Code” with a new not used Location, this way I could monitor anything that Navision transfered into that location. Regards, Humberto.

Hi, I ran into the same problem. But uncheck the ‘Location Mandatory’ in the gl-setup is not the solution. I discovered that the problem is in codeunit 21. If you look at how the error occurs while it shouldn’t come in that particular code area, brought me to some more research. There is a field on the ItemjnlLine called ‘Adjustment’. That field should be false when running ‘Adjust Cost Item Entries’. The code should be as follows in codeunit 21: IF (InvtSetup.“Location Mandatory”) AND (“Value Entry Type” = “Value Entry Type”::“Direct Cost”) THEN BEGIN IF Quantity <> 0 THEN TESTFIELD(“Location Code”); IF (“Entry Type” = “Entry Type”::Transfer) AND (NOT Adjustment) //added THEN TESTFIELD(“New Location Code”); END;

Hi, I ran into the sam eproble, i uncheck in the setup and then ran the batch job, later on debugging i found the sam ething and have done so myself. now i know that i have not done something stupid , its running smooth, Thanks Roelof. cheers venu

Hi, I found the same error. Are you sure that disabling the location mandatory field in the inventory setup is the correct solution? The adjustment entry is written correctly in this way? Thanks in advance Marco

Please apply the improvements