copy/paste from NF to MS Excel

Old problem, still not solved : If we copy records from a list form showing amounts (for example) and paste it into Excel, we don’t get numbers (problem with the thousand separator). We have to run a find/replace command to change this bad separator into a blank. It’s no-use trying to put this char in the Regional settings as my new thousands separator, it doesn’t change anything. As I didn’t read anything about that problem, perhaps it’s worth saying that we are in France (special Win95/98 settings ?). Thanks for any reply.

Which version are you using? NF 2.01 and 2.5 use the local settings for showing values. Copy/paste to Excel works excellent. John

Thanks for your reply. Whatever the version I’m using (NF and Excel), the problem still occurs (known since the NF1.1, still true on the 2.5). All our customers are aware of this issue. Could it be a problem of the localization ?

Hi, What thousand separator do you use? It should not be a problem. We had similiar problem in Russia but it can be solved… Valentin Gvozdev BMI Inc.

The standard way of showing numbers in France is following for one million : 1 000 000,00. Thousand separator=Blank

Hi, Navision use ‘Digit Grouping separator’ from Windows regional settings as thousand separator. For France and other Eropian countries it is char(160) but it looks like blank char(32). Excel use char(32) as thousand separator. This is your problem. You have some solution: - change ‘Digit Grouping separator’ in the Regional Settings. Just type blank (space). {I prefere this.} - change setup in the Excel. You need to change thousand separator from char(32) to char(160) - select other regional settings I hope it will solve your problem… Valentin Gvozdev BMI Inc.

Thanks a lot. Seems to be a stupid question once you know the solution… Nevertheless, it’s fine starting the week with a solution, Valentin !