Compilation error on build compile due to referenced dll

Hi, I am using a third party dll in my application and I have added it to the reference node in aot.

I am able to access it in the classes and dont see any compilation errors but when I run a build compile, The compiler output gives me syntax errors in the place where dll is used.

I would really appreciate if some one can help me on how can I get my build compile without errors?

The dll exists in GAC, client bin folder, vs assembly folders also.

Please tell us what you mean by build compile.

Also, we don’t know your AX version, because you forgot to attach a tag with it.

Oh yes, I am sorry, I am using ax 2012 R3 cu9 and also I mean by build compile is the fast compile using axbuild.exe, the parallel compilation.

Have you specified altbin? If not, please try it.

Can your DLL be loaded to 64-bit process?

Yes I have specified altbin parameter for axbuild.exe.

Loading DLL to 64-bit process is new to me, can you explain a little more?

When I see the details of assembly, It gives me the information that the process architecture is x86, is your question something related to this?

If your assembly is built specifically for x86, it can’t be loaded to x64 processes. Therefore it will work when compiling through AX client (32-bit process), but not when compiling on AOS (64-bit process). Note that Assembly Binding Log Viewer can help you with detecting these issues.

If you can, rebuild your assembly with Platform target: Any CPU. (Make sure it doesn’t reference other x86 assemblies).

If you can’t, I don’t think you’ll be able to use axbuild.

Thanks Martin,

Ah, I completely understood the point. Now our 3rd party software gives its software in 32 and 64 bit versions. when I install 32 bit software, as I mentioned above, Ax client being 32 bit runs and compiles code and axbuild.exe being 64bit utility fails to recognize dlls and gives syntax errors. When I install 64 bit software, the vice versa happens, the axbuild.exe compiles successfully but compiling in ax gives errors.

I also tried installing 32 bit software on PC and in client bin path(alt bit path) dropping 64 bit dlls as to give t he 64 bit dlls to axbuild.exe but that dint work either.

Il have to check if we can rebuild with Platform target: Any CPU as you suggested as we do not have the source code, I still dint attempt that option.