commerce portal synchronizatoin problem

I noticed under the computer management> Message queing a red cross beside the Outgoing queue. It is reporting a generic error on the DIRECT=TCP:\private$\jobmq I have verified my queues in the registies of both servers. I am also noticing the following error in App event log: “The operating system returned the error (121): The semaphore timeout period has expired.” Any insights??? Thanks in advance. Jamal

I rebooted my server again (because I couldn’t think anything else to do) and now the log says NAS could not initialize and will keep trying every 30 secs. The error queue has now disappeard from the Message Queue. I am using a local account with login as service and batch job for NAS. I am stumped. Jamal

Hi Jamal, Ideally NAS should run on “Administrator” A/c. You can refer to other requests on this topic in the forum where a lot of info. is put in on the synchronization issue. In one case, how i handled this NAS initialization problem is to stop CP Synch. Service and then NAS Service. Then remove NAS Service and re-install again. It worked for me. You also need to check permissions on your queues(synch/error) in MSMQ of Comp. Mgt. I would advise you to go through other requests. Regards

Thanks for replying Rahimuddin. I uninstalled and reinstalled my Navision/database server again. Did some synchronization successfuly and everything seemed to work fine for a while. Then while I was the commercie portal site doing a demo, it started to go bad for no reason. We started seeing the error below when we clickid on the “shopping Cart” link. My App/database server is on the internal network and commerce portal on the DMZ. One more thing worth mentioning is that I can’t use Windows authentication. Every time I try I get error “This server does not support windows authentication.” Error *The page cannot be displayed *We apologize for the inconvenience. Please try again later. If the problem persists, please contact our webmaster. -------------------------------------------------------------------------------- No reply received from Navision! -------------------------------------------------------------------------------- *HTML/ASP Error Type: (0x0) *Browser Type: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1) *Page: GET /bibliocentre/error.asp *Time: Monday, July 29, 2002, 9:31:10 AM _______________

Hi Jamal, What’s your Server OS?(Win NT 4.0 or Win 2k). If Win2k Check If Active Directory Services are installed? CP works only on Windows Login and even NAS uses Windows Login only to run. (Refer to CP Installation guide for more details) Reg. your other related to ‘Shopping Cart’, me too faced the same. Didn’t checked why? May be problem in Commn. with Commerce Server. But the first thing is that you need to take care of Windows Authentication. Regards

I am using Windows 2k with SP2 on both servers. Navision APP/database server is a member of workgroup. We promarily use use Windows NT 4 based domain. Doesn’t Windows2000 automatically put support Active Dirctory? I am not really sure how to enable it. My synchronization seems to be working fine since I re-installed my server. Its the error pages that I am getting on the commerce portal site about Navision server not replying. I am not sure how to trouble shoot this windows authentication problem for there is no documentataion or specific guidelines available on this. I used 2 other windows account but still got the " this servers does not support windows authentication" error. Ally my accounts are local since this server does not participate in any domain activity. Jamal

I forgot to mention that: When I used the MMC to stop the classic service, I can not restart it. It logs “unable to initialize…will keep trying every 30 seconds.” error message. It does initialize if I reboot the server. I also get: “The operating system returned the error (121): The semaphore timeout period has expired.” error message in my event log.

Are you trying on a Production(live) client or it’s for testing purpose? If i’m not wrong, your Win NT 4.0 is domain controller and you 've installed CP on another System with Win 2K. To confirm if ADS is installed or not from Navision, when you are running Navision do check Tools–>Security–>Windows Login and click lookup to select a login. Check the Mesg. you get. If it says, ADS is not installed…then you have to install it check out how with your Networking Staff. Also in Navision check the Sessions(You must have 2 sessions both running on Windows Login.) I don’t think other error rel. to shopping cart has something to do with it. Check with your NSC/NTR for manuals/info. Regards

After installation of Commerce Portal 3.10A, I am able to view latest updated data on customer from Navision Attain. However, I have error message on web page when I click to view Catalog. Error Type: CS_CtlgSets (0x80004005) The catalogset id is not valid /commerceportal/include/util.asp, line 526 Anybody has an idea ? I truly appreciate your help. Thanks in advance.

I rebuilt my navision server, keeping it very simple and not installing security patches and some Dell server utilities. I was able to use windows login and it seemed OK. I then forced a full synchronization to our commerce portal which is in the DMZ. After successfuly synchronizing, I tried to use the commerce portal, but I got the generic “no reply received from Navision” error every time I tried to put an item in shopping cart. I enabled “journal” on Message Queues and noticed that no messages were coming into the navision application server from the commerce server. I have made sure the firewall is configured and port 1801 is open for Message Queuing. The commerce portal server works fine with my temporary test Navision server which is located on the same internal network. I don’t know why commerce server can talk to the one server but not the other? I don’t know what else to look for. I do verify that my reply queue is pointing to right server in the registry editor. Any ideas??? Jamal