Check Printing Issue

I am having an issue with one user printing a check from the Payment Journal in Navision 4.02. Said user can run through the check printing procedure with no problems, however when it comes time for the check to print, nothing is printed. She is able to print other documents from Nav without difficulty, it’s only checks. I checked with our IT department and they assured me that this is a software issue. Any information would be greatly appreciated.


The first thing to check here is to see if Navision thinks the ‘checks’ have already been printed. Sometimes the printout fails, but Navision thinks they have been produced.

To find this out, you need to see if the ‘Check Printed’ field in the Journal Lines have been set to ‘Yes’. Navision only lets you print out a check once.

If they have, then there are two options: You can either re-print the checks by running the check report and making sure that re-print checks is set to Yes on the Options tab, or you can void all the checks on the journal and print them again with different check numbers depending on what you want to do.

If the Journal Lines have not had ‘Check Printed’ set to yes, then it may be due to the user not selecting ‘Computer Checks’ when running the Suggest Vendor Payments batch job and Navision does not recognize the Journal Lines as being check lines.

If this is the case, you will have to delete and regenerate the journal lnes.

Hope this is of help.

In the batches that I’ve witnessed so far the checks were not printed. I’ve sat with her through the entire process from suggesting the vendor payments through the check printing function.

There are no error messages, the check just never seems to make it to the printer but the check printed field is marked ‘yes’.

Another person can go in right behind her, void the checks, and print them all out with no problem without changes any of the information in the journal lines.

Make sure on the suggest payments screen the option tab, you have computer check entered, on your other screens they probably have this there and there zup file remembers it, but this person never filled it in, and thus the computer see nothing to print, it will suggest a line and you will see it in the journal, but nothing will print, without it being entered as type computer check.

Also check there is no user-printer setup defined where it is printing to a completely different printer.

Thanks for all of your replies. I’ll make sure to put these ideas to the test in the morning.

Thanks again.

It took a while but the printing issue appeared once again. This time a printer’s physical location was moved immediately before checks were to be printed. I tried recreating the entries in the same batch but they still would not print. I created a new batch and the checks printed without a problem. Not quite a solution but hey, it worked.