We have both Win95 and Winnt4 Uk clients running on our network. Some of them show characters like Ë (Alt+0203) in the way as it should be but on other machines, win95 and Winnt, the characters are showed like ® (Alt+0174) or Ô (Alt+0212). Is anyone familiar with this problem?

I’m not quite sure, but it sounds like the problems with have with the Danish letter Ø. Here it comes from that if you have set the computers regional settings to english, then thise letters are not supported in Navision. You must change the Default Locale to Danish (or in you case to Dutch) and reboot. If you still want the English locale, then you can change it back when the computer gets back online - just don’t change the Default Locale. Best regards, Erik P. Ernst, webmaster

The solution you gave didn’t worked out. All NT4 client have regional settings Dutch (standard) but some them work or other don’t. When the character is changed to the right one on clients where the characters shown false, then on the clients where was right it shows now false. In my opinion it is OS setting that should be corrected but we can’t fing out which settings are Ok.

It is very important that you change the DEFAULT regional settings and not the user regional settings. The default setting governs the OS’s ANSI/OEM character conversions, which is usually responsible for your type of problem. For Windows 95/98: Check the COUNTRY setting in C:\CONFIG.SYS and ensure that the country ID and code page is correct (i.e. is the same as the machines that work correctly. Code page is probably 850 that you need). Windows NT: Settings/Control Panel/Regional Settings/Regional Settings tab. Choose the required local and then ENSURE THAT THE “Set as system default locale” CHECK BOX IS CHECKED! You will need to reboot the OS. Windows 2000: Settings/Control Panel/Regional Options/General tab. CHOOSE “Set Default…” BUTTON! Then choose the required locale (i.e. don’t change the locale in the General tab). You will need to reboot the OS.

The problems for WinNT4 and 2000 are solved now but Win95 is stil a problem. Changing the setting both in regional settings, config.sys en autoexec.bat does not work… CONFIG.SYS device=c:\windows\command\display.sys con=(ega,1) country=031,850,c:\windows\command\country.sys AUTOEXEC.BAT mode con codepage prepare( (850) c:\windows\command\ega.cpi) mode con codepage select=850 keyb us,c:\windows\command\keyboard.sys

That’s correct - I remember now. There is a command that you have to run to do this on W95. I just don’t remember what command But I’m sure that our member Michael Falk knows - because he was the one who told me. Best regards, Erik P. Ernst, webmaster

Why do you have all this stuff in autoexec.bat? Try removing it, since the country setting covers your code page requirement (cp 850). The KEYB command in autoexec.bat comes from the older DOS versions, where there was no COUNTRY setting in config.sys (which was introduced with win95 DOS). Your “keyb us,…” will change your code page to 437 - from the 850 correctly set in config.sys - which is what US and UK use. Remove it!

On the original Windows 95 CD, there is a folder called Other. in this folder a ChangeCP folder resides, and in that folder there is a exe called Changecp. You must run this changecp program, and set the codepage to your country. Changes in config.sys/autoexec.bat does NOT help. You MUST use Changecp.exe

Hi Michael, This is news to me! In what way does changing config.sys NOT help with changing the OEM code page? And what is changecp.exe actually doing to the windows and dos environment? I notice that MSDN does not include this directory or file on the OS CD’s, which implies that changing code page is not possible with systems installed from here, which seems unlikely. Basically, I’m doubting the necessity for this step :slight_smile: Maybe you can explain.

We did run Changecp on the windows machines and now have the right codepages. They were in windows on 437 instead of 850. (probally during setup of W9x there is made a wrong choice for the codepage) When running Changecp there is a explanation what will be changed by the program.

To Robert The problem is special characters like the danish letter ø (o with slash) I have no idea why it is not enough to change the config.sys/autoexec.bat files, but the only way to get the ø working is by using the ChangeCp program. I don’t now exactly what the pogram does, but it copies some new system-files to the Windows-folder. Remember this description ONLY applies to Windows 95

Code page 437 doesn’t contain the ø character, amongst other, whereas 850 does. But I am interested in what changes changecp.exe has made in config.sys and/or autoexec.bat. It must have removed all references to code page 437, which were there before, in this example. I suppose the files it copies is for font support (non ANSI fonts). I’ll try and get hold of the original CD to try it. Thanks for the info.

Believe it is as simple as autoexec.bat and config.sys are used by DOS only. Windows 95 is having its own settings for the Windows environment, which only can be changed by running the changecp.exe (cp = Code Page) program. Later versions of Windows behave differently, believe there it’s connected to the regional settings. John

But for OEM character purposes, windows 9x is using the same settings as DOS. The win32 CharToOem() and Oem2Char() for conversion between OEM and ANSI characters, relies upon the config.sys setting for win9x (not, as you say, NT or 2000). This is why I believe changecp is a font issue only.