changed password and could not login


We have MS dynamics NAV running. Data base is in SQL Server 2005.

What i did when using NAV application was clicked on tools and Security then changed the password.

later again i went to tools – security – Data base logins.

We have only one user login for which i wanted to change the user id.

when i entered the user id which was not there in the database. i got a warning message that the user id does not exist in the database. from then i could not open my NAV application as the user name and password are incorrect.

Please help me with a solution what i should.

thank you


Hi all

i have changed the password to dynamics NAV login. then i tried to change the username also. but as the user name i entered is not in the data base, a warning displayed and now i could not able to login to the application. Please help me

Do u have sa user there?

Run this query from ssms:

DELETE FROM [Windows Login]

Or empty these two tables manually…

Now you should be able to get in and recreate the user+pass

ya sa is there.

i am trying to login through that but again prompting for password.

“sa” is SQL server’s sysadmin… doubt it has blank pwd…

Hi Modris,

good morning

actually SQL Server and Navision are installed in the system.

the people here telling that they have done something but the person who did was not available.

I could not find what they have done clearly. I could able to notice the chart of accounts and General ledger were done.

So i wanted to start with initial data porting and trying to take the system forward.

Mean while i have done one thing that is

here the system has only one user login created. I tried to change the password and login name.

While changing the u name the system prompted an error message that the user not exist in the database

the application closed when i punch OK.

now i could not able to login even with the old u name.

i have tried to create a new user in the db. not worked. ??


I have created a new user in the database. Given the user permission as db admin.

I could able to login to the application getting warning as you have no permission to run the MBS menu suite and also another ’ you don’t have permissions to read General ledger’

any one pl help me



Surya I mean Aumn (because you changed your username), this is the third time that you started a topic about the same thing, and the third time it was merged into the original one. Please stop creating new topics for the same issue.