Change Table Primary key screws up report!

Hi, Does anyone know an easy way to resolve this problem its driving me crazy![:(!][:(!][:(!] I created a report on table A. After fetching each record I have code that writes to Table B. (Table B’s Primary Key = F1,F2,F3,F4) It worked fine. Until I realised I had to change the primary key of Table B to F1,F2,F7,F8,F3,F4 Now, no matter what I try I cannot run the report becuase I get a message saying “The Table B table does not have active key that starts with the follwoing fields F1,F2,F3,F4” The report object seems to have cached the view of this table and won’t let go. There are no records in table B when the report starts. I even tried exporting report as text file, deleting it and then importing and compile - still no luck. Pleeeese help its driving me crazy. Jon

Hang on - might be something else - tried recreating problem as described on question and this works!

Ignore me…I’m stupid.[:I]

Hi Jon McArthur, This message occur maybe due to the design of your report. It could be : 1 : If you got a DataItem for Table B in report, pls check it’s properties call - DataItemTableView, and change the key to new key (F1,F2,F7,F8,F3,F4). 2 : Maybe you write some coding to set the key to using for Table B. Pls check whether you had wrote some coding like : “SETCURRENTKEY”. If you find it pls change the value to the new key. 3: Maybe you had created some flowfield in Table A which linkage to Table B, Create a new key contain with the old value (F1, F2, F3, F4) for Table B.